diff mbox series

[bug#44720] gnu: astroid: Fix inputs.

Message ID 20201118100306.GA20593@E5400
State Accepted
Headers show
Series [bug#44720] gnu: astroid: Fix inputs. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Efraim Flashner Nov. 18, 2020, 10:03 a.m. UTC
Can you try the attached patch? It wraps the binary in GI_TYPELIB_PATH
instead of propagating gsettings-desktop-schemas.

Comments

Tanguy LE CARROUR Nov. 18, 2020, 10:22 a.m. UTC | #1
Hi,


Excerpts from Efraim Flashner's message of November 18, 2020 11:03 am:
> Can you try the attached patch? It wraps the binary in GI_TYPELIB_PATH
> instead of propagating gsettings-desktop-schemas.

Nop, does not work! :-(

I still get the following error message on startup:

```
(astroid:7236): GLib-GIO-ERROR **: 11:19:11.738: Settings schema 'org.gnome.desktop.interface' is not installed
```
diff mbox series

Patch

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 59f49d1247..741130eab6 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -729,7 +729,10 @@  mailpack.  What can alterMIME do?
            #t))))
     (build-system cmake-build-system)
     (arguments
-     `(#:configure-flags (list "-GNinja")
+     `(#:modules ((guix build cmake-build-system)
+                  (guix build utils)
+                  (ice-9 match))
+       #:configure-flags (list "-GNinja")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'skip-markdown-test
@@ -759,7 +762,22 @@  mailpack.  What can alterMIME do?
              #t))
          (replace 'install
            (lambda _
-             (invoke "ninja" "install"))))))
+             (invoke "ninja" "install")))
+         (add-after 'install 'wrap-with-GI_TYPELIB_PATH
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out"))
+                   (paths (map (match-lambda
+                                 ((outputs . directory)
+                                  (let ((girepodir (string-append
+                                                    directory
+                                                    "/lib/girepository-1.0")))
+                                    (if (file-exists? girepodir)
+                                        girepodir
+                                        #f))))
+                               inputs)))
+               (wrap-program (string-append out "/bin/astroid")
+                 `("GI_TYPELIB_PATH" ":" prefix ,(filter identity paths))))
+             #t)))))
     (native-inputs
      `(("glib-networking" ,glib-networking)
        ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
@@ -781,6 +799,8 @@  mailpack.  What can alterMIME do?
        ("python" ,python-wrapper)
        ("python-pygobject" ,python-pygobject)
        ("webkitgtk" ,webkitgtk)))
+    (propagated-inputs
+     `(("adwaita-icon-theme" ,adwaita-icon-theme))) ; Required for the thread view
     (home-page "https://astroidmail.github.io/")
     (synopsis "GTK frontend to the notmuch mail system")
     (description