diff mbox series

[bug#44683] Miscellaneous R packages

Message ID 20201116131540.GB4512@zpidnp36
State Accepted
Headers show
Series [bug#44683] Miscellaneous R packages | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Lars-Dominik Braun Nov. 16, 2020, 1:15 p.m. UTC
Hi,

I’ve imported several R packages from CRAN using the importer. Descriptions
have been edited slightly.

Cheers,
Lars

Comments

Lars-Dominik Braun March 10, 2021, 11:53 a.m. UTC | #1
This patchset is now obsolete, since some of them have been updated in the meantime.
diff mbox series

Patch

From dd2095db08802c6481903466b58866b2e987eb60 Mon Sep 17 00:00:00 2001
From: Lars-Dominik Braun <ldb@leibniz-psychology.org>
Date: Mon, 16 Nov 2020 13:03:16 +0100
Subject: [PATCH 9/9] gnu: Add r-puniform.

* gnu/packages/cran.scm (r-puniform): New variable.
---
 gnu/packages/cran.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0caff23582..caf8cfbfc1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24911,3 +24911,37 @@  saddle-point corrections.  Tests of multiple- contrast hypotheses use an
 approximation to Hotelling's T-squared distribution.")
     (license license:gpl3)))
 
+(define-public r-puniform
+  (package
+    (name "r-puniform")
+    (version "0.2.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "puniform" version))
+       (sha256
+        (base32
+         "1y47y6s76pjvp10m8rvdh7y1iidjw96a4wrr920w0js3rn4fi1fz"))))
+    (properties `((upstream-name . "puniform")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-adgoftest" ,r-adgoftest)
+       ("r-metafor" ,r-metafor)
+       ("r-rcpp" ,r-rcpp)
+       ("r-rcpparmadillo" ,r-rcpparmadillo)))
+    (home-page
+     "https://cran.r-project.org/web/packages/puniform")
+    (synopsis
+     "Meta-Analysis Methods Correcting for Publication Bias")
+    (description
+     "This package provides meta-analysis methods that correct for publication
+bias and outcome reporting bias.  Four methods and a visual tool are currently
+included in the package.  The p-uniform method as described in
+@url{doi:10.1037/met0000025, van Assen and and van Aert and Wicherts (2015)},
+the p-uniform* method as described in @url{doi:10.31222/osf.io/zqjr9, van Aert
+and van Assen (2019)}, the hybrid method as described in
+@url{doi:10.3758/s13428-017-0967-6, van Aert and van Assen (2017)} and the
+Snapshot Bayesian Hybrid Meta-Analysis Method as described in
+@url{doi:10.1371/journal.pone.0175302, van Aert and van Assen (2018)}.")
+    (license license:gpl2+)))
+
-- 
2.25.1