diff mbox series

[bug#44681] gnu: gnubg: Prevent building with avx instructions.

Message ID 20201116121737.22825-1-mike@rohleder.de
State Accepted
Headers show
Series [bug#44681] gnu: gnubg: Prevent building with avx instructions. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Michael Rohleder Nov. 16, 2020, 12:17 p.m. UTC
* gnu/packages/games.scm (gnubg): Prevent building with avx instructions.
[arguments]: Add configure-flags for Intel systems.
---
 gnu/packages/games.scm | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)

Comments

Kei Kebreau Nov. 18, 2020, 2:27 a.m. UTC | #1
Hi Michael!

Michael Rohleder <mike@rohleder.de> writes:

> * gnu/packages/games.scm (gnubg): Prevent building with avx instructions.
> [arguments]: Add configure-flags for Intel systems.

I'd modify the commit message to be a bit shorter, like so:

gnu: gnubg: Prevent building with AVX instructions.

* gnu/packages/games.scm (gnubg)[arguments]: Add configure-flags for Intel
systems to build without AVX instructions.

> ---
>  gnu/packages/games.scm | 9 ++++++++-
>  1 file changed, 8 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index 97b0cb976d..12cc64fefa 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -1605,7 +1605,14 @@ such as chess or stockfish.")
>      (native-inputs `(("python-2" ,python-2)
>                       ("pkg-config" ,pkg-config)))
>      (arguments
> -     `(#:phases
> +     `(#:configure-flags
> +       ;; SSE instructions are available on Intel systems only.
> +       (list ,@(if (any (cute string-prefix? <> (or (%current-target-system)
> +                                                    (%current-system)))
> +                        '("x86_64" "i686"))
> +                   '("--enable-simd=sse2") ; prevent avx instructions
> +                   '()))
> +       #:phases
>         (modify-phases %standard-phases
>           (add-after 'install 'install-desktop-file
>             (lambda* (#:key outputs #:allow-other-keys)

Otherwise, the patch looks and works fine.  I didn't even know that GNU
Backgammon didn't work on my machine until I tested this patch!

Please let me know whether you're okay with the commit message
modification, and I'll push this for you.

Thanks,
Kei
Michael Rohleder Nov. 18, 2020, 6:53 a.m. UTC | #2
Hi Kei!

Kei Kebreau <kkebreau@posteo.net> writes:
> Please let me know whether you're okay with the commit message
> modification, and I'll push this for you.

This is perfectly fine!
Thank you very much for reviewing, testing, rewriting, asking and
pushing ;)
Kei Kebreau Nov. 18, 2020, 2:05 p.m. UTC | #3
Michael Rohleder <mike@rohleder.de> writes:

> Hi Kei!
>
> Kei Kebreau <kkebreau@posteo.net> writes:
>> Please let me know whether you're okay with the commit message
>> modification, and I'll push this for you.
>
> This is perfectly fine!
> Thank you very much for reviewing, testing, rewriting, asking and
> pushing ;)

You're welcome!  This patch has been pushed to master as commit
82df93e27c.
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 97b0cb976d..12cc64fefa 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1605,7 +1605,14 @@  such as chess or stockfish.")
     (native-inputs `(("python-2" ,python-2)
                      ("pkg-config" ,pkg-config)))
     (arguments
-     `(#:phases
+     `(#:configure-flags
+       ;; SSE instructions are available on Intel systems only.
+       (list ,@(if (any (cute string-prefix? <> (or (%current-target-system)
+                                                    (%current-system)))
+                        '("x86_64" "i686"))
+                   '("--enable-simd=sse2") ; prevent avx instructions
+                   '()))
+       #:phases
        (modify-phases %standard-phases
          (add-after 'install 'install-desktop-file
            (lambda* (#:key outputs #:allow-other-keys)