diff mbox series

bug#44658: Add new package

Message ID 20201115220756.2767f534@tachikoma.lepiller.eu
State Accepted
Headers show
Series bug#44658: Add new package | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Julien Lepiller Nov. 15, 2020, 9:08 p.m. UTC
Pushed as 15929beb5f1cd2bf96c53eef0f5da3e986c30530, thank you!

I did some small changes to the package definition, so I attach the
actual patch I pushed, so you can review it and hopefully learn from it
:)

When you don't need a phase, you can delete it, instead of replacing it
with a procedure that does nothing. To pass arguments to the make
command, you can use the #:make-flags argument.
diff mbox series

Patch

From 15929beb5f1cd2bf96c53eef0f5da3e986c30530 Mon Sep 17 00:00:00 2001
From: luhux <luhux@outlook.com>
Date: Sun, 15 Nov 2020 21:15:33 +0800
Subject: [PATCH] gnu: Add curseofwar

Signed-off-by: Julien Lepiller <julien@lepiller.eu>
---
 gnu/packages/games.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 439e369fe4..4ab7436daf 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -54,6 +54,7 @@ 
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Trevor Hass <thass@okstate.edu>
 ;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
+;;; Copyright © 2020 Lu hux <luhux@outlook.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -11942,3 +11943,32 @@  inside the Zenith Colony.")
 X11 that won't set your CPU on fire, drain your laptop battery, or lower video
 game FPS.")
       (license license:unlicense))))
+
+(define-public curseofwar
+  (package
+    (name "curseofwar")
+    (version "1.3.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/a-nikolaev/curseofwar")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1wd71wdnj9izg5d95m81yx3684g4zdi7fsy0j5wwnbd9j34ilz1i"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f; no tests
+       #:make-flags
+       (list "CC=gcc" "PREFIX="
+             (string-append "DESTDIR=" (assoc-ref %outputs "out")))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure))))
+    (inputs `(("ncurses" ,ncurses)))
+    (home-page "https://a-nikolaev.github.io/curseofwar/")
+    (synopsis "Fast-paced action strategy game")
+    (description "Curse of War is a fast-paced action strategy game for
+Linux originally implemented using ncurses user interface.")
+    (license license:gpl3)))
-- 
2.29.2