diff mbox series

[bug#44363] gnu: synapse: Update to 1.22.1.

Message ID 20201103193719.614-1-mike@rohleder.de
State Accepted
Headers show
Series [bug#44363] gnu: synapse: Update to 1.22.1. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Michael Rohleder Nov. 3, 2020, 7:37 p.m. UTC
* gnu/packages/matrix.scm (synapse): Update to 1.22.1.
[propagated-inputs]: Add python-packaging.
---
After playing some more with synapse, I realized it also
needs python-packaging (at runtime).

 gnu/packages/matrix.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Efraim Flashner Nov. 4, 2020, 9:25 a.m. UTC | #1
Looks good. Patch pushed.
diff mbox series

Patch

diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index 83a0d478af..6a6cc628ca 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -61,13 +61,13 @@  an LDAP server.")
 (define-public synapse
   (package
     (name "synapse")
-    (version "1.20.1")
+    (version "1.22.1")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "matrix-synapse" version))
               (sha256
                (base32
-                "1sf36vwvy2f9jy6dldq6gqfmh60384i5j64s7yc131b4dp0n7lcw"))))
+                "1pbxdqpfa7wzdz61p6x58x7841vng1g65qayxgcw73bn1shl50jb"))))
     (build-system python-build-system)
     ;; TODO Run tests with ‘PYTHONPATH=. trial3 tests’.
     (propagated-inputs
@@ -109,6 +109,7 @@  an LDAP server.")
        ("python-txacme" ,python-txacme)
        ("python-pysaml2" ,python-pysaml2)
        ("python-lxml" ,python-lxml)
+       ("python-packaging" ,python-packaging)
        ;; sentry-sdk, jaeger-client, and opentracing could be included, but
        ;; all are monitoring aids and not essential.
        ("python-pyjwt" ,python-pyjwt)))