diff mbox series

[bug#44401] gnu: poetry: Update to 1.1.4.

Message ID 20201102222624.3552-1-sl@eauchat.org
State Accepted
Headers show
Series [bug#44401] gnu: poetry: Update to 1.1.4. | expand

Checks

Context Check Description
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Sébastien Lerique Nov. 2, 2020, 10:26 p.m. UTC
* gnu/packages/python-xyz.scm (poetry): Update to 1.1.4.
---
 gnu/packages/python-xyz.scm | 20 +++-----------------
 1 file changed, 3 insertions(+), 17 deletions(-)

Comments

Sébastien Lerique Nov. 3, 2020, 12:01 a.m. UTC | #1
Dear Maintainers,

This submission was somwhat premature, as poetry 1.1.4 requires 
python-keyring 21.2.0, which in turn requires python-mypy for 
tests, which itself has failing tests on my machine. It seems I 
tried to bite too much in one go, so maybe this can be put on hold 
until I resolve the pending issues?

Apologies for submitting too fast!
Best wishes,
Sébastien
Tanguy LE CARROUR Nov. 29, 2020, 5:45 p.m. UTC | #2
Hi Sébastien,

Good to know that I'm not the only one with an interest in Poetry! :-)


> This submission was somwhat premature, as poetry 1.1.4 requires
> python-keyring 21.2.0, which in turn requires python-mypy for
> tests, which itself has failing tests on my machine. It seems I
> tried to bite too much in one go, so maybe this can be put on hold
> until I resolve the pending issues?

FYI, the upgrade to 1.1.4 is also discussed here:
https://debbugs.gnu.org/cgi/bugreport.cgi?bug=44077

It seems that there's also a problem with the latest version of keyring on Guix:
https://github.com/jaraco/keyring/issues/469
But I'm (slowly) working on it!

Happy hacking!
Sébastien Lerique Nov. 30, 2020, 9:45 a.m. UTC | #3
Hi Tanguy,

> FYI, the upgrade to 1.1.4 is also discussed here:
> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=44077

Aha, great news! I've also been working on this last week, so it 
must overlap. I read the thread -- can you point me to your latest 
complete patch and what guix commit it applies to, so I can see if 
I have anything different?

So far I had to update:
- python-keyring to 21.5.0,
- python-setuptools to 50.3.2,
- python-virtualenv to 20.2.1,
- python-distlib to 0.3.1,
- python-tomlkit to 0.7.0,
- and use requests-toolbelt-0.9.1 in poetry's package definition

And I was now missing poetry-core, which I see you have done. This 
is turning into a large patchset, and on my side it's still with 
some tests disabled (though I'm still planning to activate them).

> It seems that there's also a problem with the latest version of 
> keyring on Guix:
> https://github.com/jaraco/keyring/issues/469
> But I'm (slowly) working on it!

Yes, I found that simply adding python-setuptools (aside from 
python-setuptools-scm) to the native-inputs made the build-system 
recognize the version.

Once I have your latest patch I should probably be able to 
converge on what you have done. Here is my current patchset for 
reference: http://0x0.st/i7b_.diff , I'm working on 
4a914de930a8317cab5bc11bdb608e3a3da3d1ad. I don't know whether to 
send parts of this as separate patches or not.

Happy hacking!
Sébastien
Tanguy LE CARROUR Nov. 30, 2020, 10:08 a.m. UTC | #4
Hi Sébastien,


Excerpts from Sébastien Lerique's message of November 30, 2020 10:45 am:
> Hi Tanguy,
> 
>> FYI, the upgrade to 1.1.4 is also discussed here:
>> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=44077
> 
> Aha, great news! I've also been working on this last week, so it 
> must overlap. I read the thread -- can you point me to your latest 
> complete patch and what guix commit it applies to, so I can see if 
> I have anything different?
> 
> So far I had to update:
> - python-keyring to 21.5.0,
> - python-setuptools to 50.3.2,
> - python-virtualenv to 20.2.1,
> - python-distlib to 0.3.1,
> - python-tomlkit to 0.7.0,
> - and use requests-toolbelt-0.9.1 in poetry's package definition
> 
> And I was now missing poetry-core, which I see you have done. This 
> is turning into a large patchset, and on my side it's still with 
> some tests disabled (though I'm still planning to activate them).

The main problem is `python-distlib`. So based on Marius' comment, I
created a `python-distlib/next`.

This is part of v5 here: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=44077


>> It seems that there's also a problem with the latest version of 
>> keyring on Guix:
>> https://github.com/jaraco/keyring/issues/469
>> But I'm (slowly) working on it!
> 
> Yes, I found that simply adding python-setuptools (aside from 
> python-setuptools-scm) to the native-inputs made the build-system 
> recognize the version.

That's great!! You could add a comment with your solution to the issue,
for the sake of documenting it.


> Once I have your latest patch I should probably be able to 
> converge on what you have done. Here is my current patchset for 
> reference: http://0x0.st/i7b_.diff , I'm working on 
> 4a914de930a8317cab5bc11bdb608e3a3da3d1ad. I don't know whether to 
> send parts of this as separate patches or not.

Sounds like a plan! :-)

Can I suggest that you wait for #44077 to be merged and then submit your
improvements?!

Thanks,
Sébastien Lerique Nov. 30, 2020, 10:29 a.m. UTC | #5
Hi Tanguy,

>> So far I had to update:
>> - python-keyring to 21.5.0,
>> - python-setuptools to 50.3.2,
>> - python-virtualenv to 20.2.1,
>> - python-distlib to 0.3.1,
>> - python-tomlkit to 0.7.0,
>> - and use requests-toolbelt-0.9.1 in poetry's package 
>> definition
>>
>> And I was now missing poetry-core, which I see you have done. 
>> This
>> is turning into a large patchset, and on my side it's still 
>> with
>> some tests disabled (though I'm still planning to activate 
>> them).
>
> The main problem is `python-distlib`. So based on Marius' 
> comment, I
> created a `python-distlib/next`.
>
> This is part of v5 here: 
> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=44077
>

Indeed, the /next solution was a good idea to keep moving. I 
second your question on who/what makes sure that the /next package 
is removed once python-distlib is upgraded (maybe simply add a 
FIXME to python-distlib so whoever upgrades it is notified).

>>> It seems that there's also a problem with the latest version 
>>> of
>>> keyring on Guix:
>>> https://github.com/jaraco/keyring/issues/469
>>> But I'm (slowly) working on it!
>>
>> Yes, I found that simply adding python-setuptools (aside from
>> python-setuptools-scm) to the native-inputs made the 
>> build-system
>> recognize the version.
>
> That's great!! You could add a comment with your solution to the 
> issue,
> for the sake of documenting it.
>

Done :)

>> Once I have your latest patch I should probably be able to
>> converge on what you have done. Here is my current patchset for
>> reference: http://0x0.st/i7b_.diff , I'm working on
>> 4a914de930a8317cab5bc11bdb608e3a3da3d1ad. I don't know whether 
>> to
>> send parts of this as separate patches or not.
>
> Sounds like a plan! :-)
>
> Can I suggest that you wait for #44077 to be merged and then 
> submit your
> improvements?!

Yes! I'll do that.

Sébastien
Tanguy LE CARROUR Dec. 1, 2020, 10:38 a.m. UTC | #6
Hi Sébastien,


Excerpts from Sébastien Lerique's message of November 30, 2020 11:29 am:
>>> Once I have your latest patch I should probably be able to
>>> converge on what you have done. Here is my current patchset for
>>> reference: http://0x0.st/i7b_.diff , I'm working on
>>> 4a914de930a8317cab5bc11bdb608e3a3da3d1ad. I don't know whether
>>> to
>>> send parts of this as separate patches or not.
>>
>> Sounds like a plan! :-)
>>
>> Can I suggest that you wait for #44077 to be merged and then
>> submit your improvements?!
> 
> Yes! I'll do that.

Just to let you know that it's been merged!

Quiet a few packages still have to be rebuilt, so it took some time for
me to install it, but… everything seems to work as expected!

So, you can proceed with submitting your patches and remove the `patch-setup-py`
from `poetry`.

Thanks!
Tanguy LE CARROUR Dec. 2, 2020, 8:15 a.m. UTC | #7
Hi Sébastien,

Excerpts from Tanguy LE CARROUR's message of December 1, 2020 11:38 am:
> Excerpts from Sébastien Lerique's message of November 30, 2020 11:29 am:
>>>> Once I have your latest patch I should probably be able to
>>>> converge on what you have done. Here is my current patchset for
>>>> reference: http://0x0.st/i7b_.diff , I'm working on
>>>> 4a914de930a8317cab5bc11bdb608e3a3da3d1ad. I don't know whether
>>>> to
>>>> send parts of this as separate patches or not.
>>>
>>> Sounds like a plan! :-)
>>>
>>> Can I suggest that you wait for #44077 to be merged and then
>>> submit your improvements?!
>> 
>> Yes! I'll do that.
> 
> Just to let you know that it's been merged!
> 
> Quiet a few packages still have to be rebuilt, so it took some time for
> me to install it, but… everything seems to work as expected!
> 
> So, you can proceed with submitting your patches and remove the `patch-setup-py`
> from `poetry`.

Unfortunately, `python-packaging` patch got reverted because it was
triggering to many rebuilds! :-(
So Poetry is broken again!

…WIP!
Marius Bakke Dec. 3, 2020, 9:49 p.m. UTC | #8
Tanguy LE CARROUR <tanguy@bioneland.org> skriver:

> Hi Sébastien,
>
> Excerpts from Tanguy LE CARROUR's message of December 1, 2020 11:38 am:
>> Excerpts from Sébastien Lerique's message of November 30, 2020 11:29 am:
>>>>> Once I have your latest patch I should probably be able to
>>>>> converge on what you have done. Here is my current patchset for
>>>>> reference: http://0x0.st/i7b_.diff , I'm working on
>>>>> 4a914de930a8317cab5bc11bdb608e3a3da3d1ad. I don't know whether
>>>>> to
>>>>> send parts of this as separate patches or not.
>>>>
>>>> Sounds like a plan! :-)
>>>>
>>>> Can I suggest that you wait for #44077 to be merged and then
>>>> submit your improvements?!
>>> 
>>> Yes! I'll do that.
>> 
>> Just to let you know that it's been merged!
>> 
>> Quiet a few packages still have to be rebuilt, so it took some time for
>> me to install it, but… everything seems to work as expected!
>> 
>> So, you can proceed with submitting your patches and remove the `patch-setup-py`
>> from `poetry`.
>
> Unfortunately, `python-packaging` patch got reverted because it was
> triggering to many rebuilds! :-(
> So Poetry is broken again!

I believe Poetry should be working now, with commit
d18a4375f30afa06c5b08a7e0f7d972a7e8296ee.  Please open a new report if
not.  Thank you both!
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ee1f9acda0..01c2d2648f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12946,7 +12946,7 @@  database, file, dict stores.  Cachy supports python versions 2.7+ and 3.2+.")
 (define-public poetry
   (package
     (name "poetry")
-    (version "1.0.10")
+    (version "1.1.4")
     ;; Poetry can only be built from source with Poetry.
     (source
      (origin
@@ -12954,24 +12954,10 @@  database, file, dict stores.  Cachy supports python versions 2.7+ and 3.2+.")
        (uri (pypi-uri "poetry" version))
        (sha256
         (base32
-         "1wm66xlsls4f0q4skmq96yb7aahjsqwgwvbrw4iax6rd4xfqj6sb"))))
+         "1a2kgfiw66fvxhlqk5qc83s6l38czfh5hcsrbiy7qq5yfc8mlsll"))))
     (build-system python-build-system)
     (arguments
-     `(#:tests? #f ;; Pypi does not have tests.
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'build 'patch-setup-py
-           (lambda _
-             (substitute* "setup.py"
-               ;; poetry won't update version as 21.0.0 relies on python > 3.6
-               (("keyring>=20.0.1,<21.0.0") "keyring>=21.0.0,<22.0.0")
-               (("pyrsistent>=0.14.2,<0.15.0") "pyrsistent>=0.14.2,<0.17.0")
-               ;; Reported upstream:
-               ;; <https://github.com/python-poetry/poetry/issues/2752>.
-               (("tomlkit>=0.5.11,<0.6.0") "tomlkit>=0.5.11,<0.7.0")
-               (("cleo>=0.7.6,<0.8.0") "cleo>=0.7.6,<0.9.0")
-               (("clikit>=0.4.2,<0.5.0") "clikit>=0.4.2,<0.7.0"))
-             #t)))))
+     `(#:tests? #f)) ;; Pypi does not have tests.
     (propagated-inputs
      `(("python-cachecontrol" ,python-cachecontrol)
        ("python-cachy" ,python-cachy)