diff mbox series

[bug#44398] gnu: Add python-boto3.

Message ID 20201102190508.17191-1-r.majd@pantherx.org
State Accepted
Headers show
Series [bug#44398] gnu: Add python-boto3. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Reza Alizadeh Majd Nov. 2, 2020, 7:05 p.m. UTC
* gnu/packages/python-xyz.scm (python-boto3): New variable.
---
 gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Reza Alizadeh Majd Nov. 2, 2020, 7:28 p.m. UTC | #1
sorry, it seems that there is an issue during build of this package.
so I close this patch and submit a new one whenever the build issue
has been resolved.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ee1f9acda0..e087da1e55 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11094,6 +11094,29 @@  manipulation library.")
 interface to the Amazon Web Services (AWS) API.")
     (license license:asl2.0)))
 
+(define-public python-boto3
+  (package
+    (name "python-boto3")
+    (version "1.16.9")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "boto3" version))
+        (sha256
+          (base32
+            "1smrfjpnki71dkdbj3zpfqi39gbcr5yb4q74fzl35hs953sf9zrs"))))
+    (build-system python-build-system)
+    (propagated-inputs
+      `(("python-botocore" ,python-botocore)
+        ("python-jmespath" ,python-jmespath)
+        ("python-s3transfer" ,python-s3transfer)))
+    (home-page "https://github.com/boto/boto3")
+    (synopsis "The AWS SDK for Python")
+    (description "Boto3 is the Amazon Web Services (AWS) Software Development
+Kit (SDK) for Python, which allows Python developers to write software that
+makes use of services like Amazon S3 and Amazon EC2.")
+    (license license:asl2.0)))
+
 (define-public python2-botocore
   (package-with-python2 python-botocore))