diff mbox series

[bug#44385] gnu: stumpish: Fix xprop call.

Message ID 20201102053027.9850-1-mike@rohleder.de
State Accepted
Headers show
Series [bug#44385] gnu: stumpish: Fix xprop call. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Michael Rohleder Nov. 2, 2020, 5:30 a.m. UTC
* gnu/packages/wm.scm (stumpish): Fix xprop call.
[inputs]: Add xprop.
[arguments]: Add substitution of xprop.
---
starting stumpish yields:
/gnu/store/3dd14k2g5v67jm0hv0cmpvkvdk4631c5-stumpish-0.0.1-2.920f8fc/bin/stumpish: line 83: xprop: command not found
/gnu/store/3dd14k2g5v67jm0hv0cmpvkvdk4631c5-stumpish-0.0.1-2.920f8fc/bin/stumpish: line 55: xprop: command not found

and after typing "commands" in the repl the same error results in no output.

 gnu/packages/wm.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

Comments

Guillaume Le Vaillant Nov. 2, 2020, 9:08 a.m. UTC | #1
Pushed to master as 48b00a4c7efadbb654bf28e9e4e61bb23f70a964. Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 58252e7095..b76542692c 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -36,6 +36,7 @@ 
 ;;; Copyright © 2020 Boris A. Dekshteyn <harlequin78@gmail.com>
 ;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
 ;;; Copyright © 2020 EuAndreh <eu@euandre.org>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1722,7 +1723,8 @@  productive, customizable lisp based systems.")
     (name "stumpish")
     (inputs
      `(("bash" ,bash)
-       ("rlwrap" ,rlwrap)))
+       ("rlwrap" ,rlwrap)
+       ("xprop" ,xprop)))
     (build-system trivial-build-system)
     (arguments
      '(#:modules ((guix build utils))
@@ -1734,6 +1736,8 @@  productive, customizable lisp based systems.")
          (substitute* "stumpish"
            (("rlwrap") (string-append (assoc-ref %build-inputs "rlwrap")
                                       "/bin/rlwrap"))
+           (("xprop") (string-append (assoc-ref %build-inputs "xprop")
+                                      "/bin/xprop"))
            (("/bin/sh") (string-append (assoc-ref %build-inputs "bash")
                                        "/bin/bash")))
          (install-file "stumpish" (string-append %output "/bin")))))