diff mbox series

[bug#44376] gnu: Add icedove-wayland.

Message ID 20201101193908.29681-1-jonathan.brielmaier@web.de
State Accepted
Headers show
Series [bug#44376] gnu: Add icedove-wayland. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Jonathan Brielmaier Nov. 1, 2020, 7:39 p.m. UTC
* gnu/packages/gnuzilla.scm (icedove/wayland): New variable.
---
 gnu/packages/gnuzilla.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

--
2.29.2

Comments

Jonathan Brielmaier Nov. 1, 2020, 7:42 p.m. UTC | #1
I don't know if that is the best way to have icedove running on Wayland.
At least it works and give me a decent HiDPI experience on sway :)
Marius Bakke Nov. 10, 2020, 9:07 p.m. UTC | #2
Jonathan Brielmaier <jonathan.brielmaier@web.de> writes:

> I don't know if that is the best way to have icedove running on Wayland.
> At least it works and give me a decent HiDPI experience on sway :)

Awesome, applied!
diff mbox series

Patch

diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index db67d7ad0a..b6e68c8132 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1476,6 +1476,27 @@  standards of the IceCat project.")
 Thunderbird.  It supports email, news feeds, chat, calendar and contacts.")
     (license license:mpl2.0)))

+(define-public icedove/wayland
+  (package/inherit icedove
+    (name "icedove-wayland")
+    (arguments
+     (substitute-keyword-arguments (package-arguments icedove)
+       ((#:phases phases)
+        `(modify-phases ,phases
+          (replace 'wrap-program
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (lib (string-append out "/lib"))
+                    (gtk (assoc-ref inputs "gtk+"))
+                    (gtk-share (string-append gtk "/share"))
+                    (pulseaudio (assoc-ref inputs "pulseaudio"))
+                    (pulseaudio-lib (string-append pulseaudio "/lib")))
+               (wrap-program (car (find-files lib "^icedove$"))
+                 `("MOZ_ENABLE_WAYLAND" = ("1"))
+                 `("XDG_DATA_DIRS" prefix (,gtk-share))
+                 `("LD_LIBRARY_PATH" prefix (,pulseaudio-lib)))
+               #t)))))))))
+
 (define-public firefox-decrypt
   (package
     (name "firefox-decrypt")