diff mbox series

[bug#44359,2/2] gnu: pre-commit: Update to 2.8.1.

Message ID 20201031200551.6451-1-monego@posteo.net
State Accepted
Headers show
Series [bug#44359,1/2] gnu: Add python-re-assert. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Vinicius Monego Oct. 31, 2020, 8:05 p.m. UTC
* gnu/packages/version-control.scm (pre-commit): Update to 2.8.1.
[arguments]: Skip new dotnet and nodejs tests.
[native-inputs]: Add python-re-assert.
[inputs]: Propagate.
---
 gnu/packages/version-control.scm | 17 +++++++++++++----
 1 file changed, 13 insertions(+), 4 deletions(-)

Comments

Marius Bakke Nov. 10, 2020, 8:37 p.m. UTC | #1
Applied both patches, thanks!

[...]

Vinicius Monego <monego@posteo.net> writes:

> * gnu/packages/version-control.scm (pre-commit): Update to 2.8.1.
> [arguments]: Skip new dotnet and nodejs tests.
> [native-inputs]: Add python-re-assert.
> [inputs]: Propagate.

It would be clearer to make the inputs propagated in a separate commit,
but obviously not a strong opinion.
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 036c0fa09b..38fab2996a 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -93,6 +93,7 @@ 
   #:use-module (gnu packages perl-check)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-check)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages readline)
@@ -1441,7 +1442,7 @@  control to Git repositories.")
 (define-public pre-commit
   (package
     (name "pre-commit")
-    (version "2.7.1")
+    (version "2.8.1")
     (source
      (origin
        ;; No tests in the PyPI tarball.
@@ -1451,7 +1452,7 @@  control to Git repositories.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0n7qby5a4yz3s02nqcp5js6jg9wrd0x7msblxwb1883ds4b2b71a"))))
+        (base32 "0b3ks6viccq3n4p8i8zgfd40vp1k5nkhmmlz7p4nxcdizw8zxgn8"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -1492,6 +1493,12 @@  control to Git repositories.")
                       " and not test_additional_rust_lib_dependencies_installed"
                       " and not test_local_rust_additional_dependencies"
                       " and not test_rust_hook"
+                      ;; Disable dotnet tests.
+                      " and not test_dotnet_hook"
+                      ;; Disable nodejs tests.
+                      " and not test_unhealthy_if_system_node_goes_missing"
+                      " and not test_installs_without_links_outside_env"
+                      " and not test_healthy_system_node"
                       ;; Disable python2 test.
                       " and not test_switch_language_versions_doesnt_clobber"
                       ;; These tests try to open a network socket.
@@ -1534,8 +1541,10 @@  control to Git repositories.")
                #t))))))
     (native-inputs
      `(("git" ,git-minimal)
-       ("python-pytest" ,python-pytest)))
-    (inputs
+       ("python-pytest" ,python-pytest)
+       ("python-re-assert" ,python-re-assert)))
+    ;; Propagate because pre-commit is also used as a module.
+    (propagated-inputs
      `(("python-cfgv" ,python-cfgv)
        ("python-identify" ,python-identify)
        ("python-nodeenv" ,python-nodeenv)