diff mbox series

[bug#44325] gnu: esbuild: Update to 0.8.0.

Message ID 20201030043207.26109-1-rprior@protonmail.com
State Accepted
Headers show
Series [bug#44325] gnu: esbuild: Update to 0.8.0. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Ryan Prior Oct. 30, 2020, 4:32 a.m. UTC
* gnu/packages/web.scm (esbuild): Update to 0.8.0.
---
 gnu/packages/web.scm | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

Comments

Ludovic Courtès Oct. 31, 2020, 10:13 p.m. UTC | #1
Hi,

Ryan Prior <rprior@protonmail.com> skribis:

> * gnu/packages/web.scm (esbuild): Update to 0.8.0.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b3e156b9eb..b3686783b5 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1424,7 +1424,7 @@  used to validate and fix HTML data.")
 (define-public esbuild
   (package
     (name "esbuild")
-    (version "0.7.16")
+    (version "0.8.0")
     (source
      (origin
        (method git-fetch)
@@ -1434,7 +1434,7 @@  used to validate and fix HTML data.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0lmq7yqssnc1cgd63m5zl734ahf8c0q0k1p2zdcn3qm15wfz7sh7"))
+         "17qzmadjixjivwbxbj20683j3n6igk7bx7v4k5bs2rqfvigdx2ps"))
        (modules '((guix build utils)))
        (snippet
         '(begin
@@ -1449,14 +1449,14 @@  used to validate and fix HTML data.")
        (modify-phases %standard-phases
          (replace 'check
            (lambda* (#:key tests? unpack-path #:allow-other-keys)
-             (if tests?
+             (when tests?
                (with-directory-excursion (string-append "src/" unpack-path)
                  (invoke "make" "test-go")))
              #t)))))
     (inputs
-     `(("go-golang-org-x-sys" ,go-golang-org-x-sys)))
+     `(("golang.org/x/sys" ,go-golang-org-x-sys)))
     (native-inputs
-     `(("go-github-com-kylelemons-godebug" ,go-github-com-kylelemons-godebug)))
+     `(("github.com/kylelemons/godebug" ,go-github-com-kylelemons-godebug)))
     (home-page "https://github.com/evanw/esbuild")
     (synopsis "Bundler and minifier tool for JavaScript and TypeScript")
     (description