diff mbox series

[bug#44276] gnu: Add python-simpleaudio.

Message ID 20201028090810.21543-1-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#44276] gnu: Add python-simpleaudio. | expand

Commit Message

Tanguy LE CARROUR Oct. 28, 2020, 9:08 a.m. UTC
* gnu/packages/python-xyz.scm (python-simpleaudio): New variable.
---
 gnu/packages/python-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Leo Famulari Oct. 28, 2020, 4:32 p.m. UTC | #1
On Wed, Oct 28, 2020 at 10:08:10AM +0100, Tanguy Le Carrour wrote:
> * gnu/packages/python-xyz.scm (python-simpleaudio): New variable.

Thanks! Pushed as 36c74e27a830cef8c63973f6a35138209dfd26ae
Leo Famulari Oct. 28, 2020, 4:43 p.m. UTC | #2
On Wed, Oct 28, 2020 at 10:08:10AM +0100, Tanguy Le Carrour wrote:
> * gnu/packages/python-xyz.scm (python-simpleaudio): New variable.

> +    (native-inputs
> +      `(("alsa-lib" ,alsa-lib)))

After taking a closer look at the inputs in the pydub package, I noticed
that alsa-lib is a native-input; native-inputs are typically used only
while building the package.

The built package keeps a reference to alsa-lib:

------
$ guix gc --references $(./pre-inst-env guix build --no-grafts python-simpleaudio) | grep alsa-lib
/gnu/store/zcjdb23gbhl0pcnvvm8rnlprkfl43cv5-alsa-lib-1.2.2
$ grep -r alsa-lib $(./pre-inst-env guix build --no-grafts python-simpleaudio)         
Binary file /gnu/store/kaiww0wf6a7kqzrn9la681lmwmp2k26w-python-simpleaudio-1.0.4/lib/python3.8/site-packages/simpleaudio/_simpleaudio.cpython-38-x86_64-linux-gnu.so matches
------

Either the reference is used and should not be the "native alsa-lib" (in
terms of cross-compiling), or it's not used and we can remove the
reference after building. I think the first option is more likely.
Should I change it from a 'native-input' to an 'input'?
Tanguy LE CARROUR Oct. 29, 2020, 8:30 a.m. UTC | #3
Hi Leo,


Le 10/28, Leo Famulari a écrit :
> On Wed, Oct 28, 2020 at 10:08:10AM +0100, Tanguy Le Carrour wrote:
> > * gnu/packages/python-xyz.scm (python-simpleaudio): New variable.
> 
> > +    (native-inputs
> > +      `(("alsa-lib" ,alsa-lib)))
> 
> After taking a closer look at the inputs in the pydub package, I noticed
> that alsa-lib is a native-input; native-inputs are typically used only
> while building the package.
> 
> The built package keeps a reference to alsa-lib:
> 
> ------
> $ guix gc --references $(./pre-inst-env guix build --no-grafts python-simpleaudio) | grep alsa-lib
> /gnu/store/zcjdb23gbhl0pcnvvm8rnlprkfl43cv5-alsa-lib-1.2.2
> $ grep -r alsa-lib $(./pre-inst-env guix build --no-grafts python-simpleaudio)         
> Binary file /gnu/store/kaiww0wf6a7kqzrn9la681lmwmp2k26w-python-simpleaudio-1.0.4/lib/python3.8/site-packages/simpleaudio/_simpleaudio.cpython-38-x86_64-linux-gnu.so matches
> ------
> 
> Either the reference is used and should not be the "native alsa-lib" (in
> terms of cross-compiling), or it's not used and we can remove the
> reference after building. I think the first option is more likely.
> Should I change it from a 'native-input' to an 'input'?

Way out of my comfort zone! ^_^'
Even if I think I get your point! `alsa-lib` is indeed used at run time.
So… do as you think is best! :-)

Thank again for your time and advice.
Leo Famulari Oct. 29, 2020, 2:14 p.m. UTC | #4
On Thu, Oct 29, 2020 at 09:30:51AM +0100, Tanguy Le Carrour wrote:
> Way out of my comfort zone! ^_^'
> Even if I think I get your point! `alsa-lib` is indeed used at run time.
> So… do as you think is best! :-)

Alright :) I made it a regular input with commit
bda1359b8e2ff36e10bce92475ce615211925342
Tanguy LE CARROUR Oct. 29, 2020, 2:26 p.m. UTC | #5
Le 10/29, Leo Famulari a écrit :
> On Thu, Oct 29, 2020 at 09:30:51AM +0100, Tanguy Le Carrour wrote:
> > Way out of my comfort zone! ^_^'
> > Even if I think I get your point! `alsa-lib` is indeed used at run time.
> > So… do as you think is best! :-)
> 
> Alright :) I made it a regular input with commit
> bda1359b8e2ff36e10bce92475ce615211925342

Thanks!!
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6c5ccac647..a60e869db8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1843,6 +1843,30 @@  after Andy Lester’s Perl module WWW::Mechanize.")
 (define-public python2-mechanize
   (package-with-python2 python-mechanize))
 
+(define-public python-simpleaudio
+  (package
+    (name "python-simpleaudio")
+    (version "1.0.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "simpleaudio" version))
+       (sha256
+        (base32
+         "07glihg0fpca0gvbbvqs9q815w8xhflzdvg72yvlsm23j9j8h739"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f))
+    (native-inputs
+      `(("alsa-lib" ,alsa-lib)))
+    (home-page
+     "https://github.com/hamiltron/py-simple-audio")
+    (synopsis "Simple, asynchronous audio playback for Python 3")
+    (description
+     "The @code{simplaudio} package provides cross-platform, dependency-free
+audio playback capability for Python 3 on OSX, Windows, and Linux.")
+    (license license:expat))) ; MIT license
+
 (define-public python-simplejson
   (package
     (name "python-simplejson")