diff mbox series

[bug#44251] gnu: Add pwclient.

Message ID 20201027094602.13503-1-mail@cbaines.net
State Accepted
Headers show
Series [bug#44251] gnu: Add pwclient. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Christopher Baines Oct. 27, 2020, 9:46 a.m. UTC
* gnu/packages/patchutils.scm (pwclient): New variable.
---
 gnu/packages/patchutils.scm | 41 +++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

Comments

Leo Famulari Oct. 27, 2020, 11:05 p.m. UTC | #1
On Tue, Oct 27, 2020 at 09:46:02AM +0000, Christopher Baines wrote:
> * gnu/packages/patchutils.scm (pwclient): New variable.

> +         (add-after 'unpack 'patch
> +           (lambda _
> +             (substitute* "test-requirements.txt"
> +               (("pytest>=3.0,<5.0;")
> +                "pytest>=3.0,<6.0;"))
> +             #t))

I would call the phase 'patch-requirements' or similar and add a brief
comment explaining it.

> +    (native-inputs
> +     `(("npython-pbr" ,python-pbr)

Typo here --^
Christopher Baines Oct. 28, 2020, 1:30 p.m. UTC | #2
Leo Famulari <leo@famulari.name> writes:

> On Tue, Oct 27, 2020 at 09:46:02AM +0000, Christopher Baines wrote:
>> * gnu/packages/patchutils.scm (pwclient): New variable.
>
>> +         (add-after 'unpack 'patch
>> +           (lambda _
>> +             (substitute* "test-requirements.txt"
>> +               (("pytest>=3.0,<5.0;")
>> +                "pytest>=3.0,<6.0;"))
>> +             #t))
>
> I would call the phase 'patch-requirements' or similar and add a brief
> comment explaining it.

I've renamed the phase now, and added a comment.

>> +    (native-inputs
>> +     `(("npython-pbr" ,python-pbr)
>
> Typo here --^

Indeed, I've removed the rogue n.

I've sent an updated patch, which fixes a few more things as well.
Leo Famulari Oct. 28, 2020, 3:36 p.m. UTC | #3
On Wed, Oct 28, 2020 at 01:30:46PM +0000, Christopher Baines wrote:
> I've sent an updated patch, which fixes a few more things as well.

Alright, then you can push as you see fit :)
Christopher Baines Oct. 28, 2020, 4:53 p.m. UTC | #4
Leo Famulari <leo@famulari.name> writes:

> On Wed, Oct 28, 2020 at 01:30:46PM +0000, Christopher Baines wrote:
>> I've sent an updated patch, which fixes a few more things as well.
>
> Alright, then you can push as you see fit :)

Thanks for taking a look! I've pushed this to master as
f6839fed5f2052fd257b4af73effb10dcd9bf35b now.
diff mbox series

Patch

diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index 12dd472c68..e0ed30070b 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -468,3 +468,44 @@  patches, and displays the patches along with comments and state information.
 Users can login allowing them to change the state of patches.")
     (home-page "http://jk.ozlabs.org/projects/patchwork/")
     (license gpl2+)))
+
+(define-public pwclient
+  (package
+    (name "pwclient")
+    (version "1.3.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/getpatchwork/pwclient")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1xckwvcqklzpyh3xs4k2zm40ifp0q5fdkj2vmgb8vhfvl1ivs6jv"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch
+           (lambda _
+             (substitute* "test-requirements.txt"
+               (("pytest>=3.0,<5.0;")
+                "pytest>=3.0,<6.0;"))
+             #t))
+         (add-before 'build 'set-PBR_VERSION
+           (lambda _
+             (setenv "PBR_VERSION"
+                     ,version)
+             #t)))))
+    (native-inputs
+     `(("npython-pbr" ,python-pbr)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-cov" ,python-pytest-cov)
+       ("python-mock" ,python-mock)))
+    (home-page
+     "https://github.com/getpatchwork/pwclient")
+    (synopsis "Command-line client for the Patchwork patch tracking tool")
+    (description
+     "pwclient is a VCS-agnostic tool for interacting with Patchwork, the
+web-based patch tracking system.")
+    (license gpl2+)))