diff mbox series

[bug#44227] gnu: guile-sparql: Update to 0.0.8.

Message ID 20201026003927.18539-1-goodoldpaul@autistici.org
State Accepted
Headers show
Series [bug#44227] gnu: guile-sparql: Update to 0.0.8. | expand

Checks

Context Check Description
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Giacomo Leidi Oct. 26, 2020, 12:39 a.m. UTC
* gnu/packages/guile-xyz.scm (guile-sparql): Update to 0.0.8.
[arguments]: Enable tests.
[inputs]: Switch to Guile 3.0.
---
 gnu/packages/guile-xyz.scm | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

Comments

Roel Janssen Oct. 26, 2020, 7:51 a.m. UTC | #1
Hi Giacomo,

Thank you for your work on guile-sparql, and for this patch!

On Mon, 2020-10-26 at 01:39 +0100, Giacomo Leidi wrote:
> * gnu/packages/guile-xyz.scm (guile-sparql): Update to 0.0.8.
> [arguments]: Enable tests.
> [inputs]: Switch to Guile 3.0.
> ---
>  gnu/packages/guile-xyz.scm | 7 +++----
>  1 file changed, 3 insertions(+), 4 deletions(-)
> 
> diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
> index 88c0586dc9..6cdf3e1604 100644
> --- a/gnu/packages/guile-xyz.scm
> +++ b/gnu/packages/guile-xyz.scm
> @@ -1064,20 +1064,19 @@ allows users to interact with the Guile REPL
> through Jupyter.")
>  (define-public guile-sparql
>    (package
>     (name "guile-sparql")
> -   (version "0.0.7")
> +   (version "0.0.8")
>     (source (origin
>              (method url-fetch)
>              (uri (string-append
>                   
> "https://github.com/roelj/guile-sparql/releases/download/"
>                    version "/guile-sparql-" version ".tar.gz"))
>              (sha256
> -             (base32
> "1drnvhsgl0gc5crmb16yyw1j98nkhwwcgssv9vgm36ng43nnzffd"))))
> +             (base32
> "1jf4972f9fpm0rd865xpnc9mzl3xv6vhfnp0iygadydy905z9nln"))))
>     (build-system gnu-build-system)
> -   (arguments `(#:tests? #f)) ; There are no tests.
>     (native-inputs
>      `(("pkg-config" ,pkg-config)))
>     (inputs
> -    `(("guile" ,guile-2.2)))
> +    `(("guile" ,guile-3.0)))
>     (home-page "https://github.com/roelj/guile-sparql")
>     (synopsis "SPARQL module for Guile")
>     (description "This package provides the functionality to query a
> SPARQL

LGTM! Pushed in 22213308f3bcc41bd2356ccbb7350a74c1426a0a.

Kind regards,
Roel Janssen
Christopher Baines Oct. 27, 2020, 9:47 a.m. UTC | #2
Roel Janssen <roel@gnu.org> writes:

> Hi Giacomo,
>
> Thank you for your work on guile-sparql, and for this patch!
>
> On Mon, 2020-10-26 at 01:39 +0100, Giacomo Leidi wrote:
>> * gnu/packages/guile-xyz.scm (guile-sparql): Update to 0.0.8.
>> [arguments]: Enable tests.
>> [inputs]: Switch to Guile 3.0.
>> ---
>>  gnu/packages/guile-xyz.scm | 7 +++----
>>  1 file changed, 3 insertions(+), 4 deletions(-)
>> 
>> diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
>> index 88c0586dc9..6cdf3e1604 100644
>> --- a/gnu/packages/guile-xyz.scm
>> +++ b/gnu/packages/guile-xyz.scm
>> @@ -1064,20 +1064,19 @@ allows users to interact with the Guile REPL
>> through Jupyter.")
>>  (define-public guile-sparql
>>    (package
>>     (name "guile-sparql")
>> -   (version "0.0.7")
>> +   (version "0.0.8")
>>     (source (origin
>>              (method url-fetch)
>>              (uri (string-append
>>                   
>> "https://github.com/roelj/guile-sparql/releases/download/"
>>                    version "/guile-sparql-" version ".tar.gz"))
>>              (sha256
>> -             (base32
>> "1drnvhsgl0gc5crmb16yyw1j98nkhwwcgssv9vgm36ng43nnzffd"))))
>> +             (base32
>> "1jf4972f9fpm0rd865xpnc9mzl3xv6vhfnp0iygadydy905z9nln"))))
>>     (build-system gnu-build-system)
>> -   (arguments `(#:tests? #f)) ; There are no tests.
>>     (native-inputs
>>      `(("pkg-config" ,pkg-config)))
>>     (inputs
>> -    `(("guile" ,guile-2.2)))
>> +    `(("guile" ,guile-3.0)))
>>     (home-page "https://github.com/roelj/guile-sparql")
>>     (synopsis "SPARQL module for Guile")
>>     (description "This package provides the functionality to query a
>> SPARQL
>
> LGTM! Pushed in 22213308f3bcc41bd2356ccbb7350a74c1426a0a.

Looks like this has been pushed, so I'm closing the bug.
diff mbox series

Patch

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 88c0586dc9..6cdf3e1604 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1064,20 +1064,19 @@  allows users to interact with the Guile REPL through Jupyter.")
 (define-public guile-sparql
   (package
    (name "guile-sparql")
-   (version "0.0.7")
+   (version "0.0.8")
    (source (origin
             (method url-fetch)
             (uri (string-append
                   "https://github.com/roelj/guile-sparql/releases/download/"
                   version "/guile-sparql-" version ".tar.gz"))
             (sha256
-             (base32 "1drnvhsgl0gc5crmb16yyw1j98nkhwwcgssv9vgm36ng43nnzffd"))))
+             (base32 "1jf4972f9fpm0rd865xpnc9mzl3xv6vhfnp0iygadydy905z9nln"))))
    (build-system gnu-build-system)
-   (arguments `(#:tests? #f)) ; There are no tests.
    (native-inputs
     `(("pkg-config" ,pkg-config)))
    (inputs
-    `(("guile" ,guile-2.2)))
+    `(("guile" ,guile-3.0)))
    (home-page "https://github.com/roelj/guile-sparql")
    (synopsis "SPARQL module for Guile")
    (description "This package provides the functionality to query a SPARQL