diff mbox series

[bug#44197] gnu: khal: Update to 0.10.2.

Message ID 20201024182333.GA69388@noor.fritz.box
State Accepted
Headers show
Series [bug#44197] gnu: khal: Update to 0.10.2. | expand

Checks

Context Check Description
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Lars-Dominik Braun Oct. 24, 2020, 6:23 p.m. UTC
* gnu/packages/calendar.scm (khal): Update to 0.10.2.
[source]: Drop upstream patches.
[arguments]: Drop substitute* for bug fixed upstream and ignore failing
test in 'check.
[inputs]: Add missing inputs.
---
 gnu/packages/calendar.scm | 46 +++++++++++++++------------------------
 1 file changed, 18 insertions(+), 28 deletions(-)

Comments

Leo Famulari Oct. 25, 2020, 6:14 p.m. UTC | #1
On Sat, Oct 24, 2020 at 08:23:33PM +0200, Lars-Dominik Braun wrote:
> * gnu/packages/calendar.scm (khal): Update to 0.10.2.
> [source]: Drop upstream patches.
> [arguments]: Drop substitute* for bug fixed upstream and ignore failing
> test in 'check.
> [inputs]: Add missing inputs.

Thanks!

Unfortunately, the second part of the patch ("hunk 2") does not apply to
the latest Guix Git master branch:

> @@ -198,19 +188,14 @@ data units.")
>               "doc/build/man/khal.1"
>               (string-append (assoc-ref outputs "out") "/share/man/man1"))
>              #t))
> -        (add-before 'check 'fix-tests
> -          (lambda _
> -            ;; Reported upstream: <https://github.com/pimutils/khal/issues/947>.
> -            (substitute* "tests/cli_test.py"
> -             (("Invalid value for \"\\[ICS\\]\"") "Invalid value for \\'[ICS]\\'"))
> -            #t))
>          (replace 'check
> -          (lambda* (#:key inputs #:allow-other-keys)
> -            ;; The tests require us to choose a timezone.
> -            (setenv "TZ"
> -                    (string-append (assoc-ref inputs "tzdata")
> -                                   "/share/zoneinfo/Zulu"))
> -            (invoke "py.test" "tests"))))))
> +          (lambda* (#:key inputs tests? #:allow-other-keys)
> +            (if tests?
> +                (begin
> +                  ;; The tests require us to choose a timezone.
> +                  (setenv "TZ" "UTC")
> +                  ;; The disabled test expects /dev/tty.
> +                  (invoke "pytest" "tests" "-k" "not test_import_from_stdin"))))))))
>      (native-inputs
>       `(("python-pytest" ,python-pytest)
>         ("python-pytest-cov" ,python-pytest-cov)

Can you double-check and see if there is something else in your local
copy of the Guix source code?
diff mbox series

Patch

diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 1dde978d72..dabf8bfb15 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -168,23 +168,13 @@  data units.")
 (define-public khal
   (package
     (name "khal")
-    (version "0.10.1")
+    (version "0.10.2")
     (source (origin
-             (method url-fetch)
-             (uri (pypi-uri "khal" version))
-             (sha256
-              (base32
-               "1r8bkgjwkh7i8ygvsv51h1cnax50sb183vafg66x5snxf3dgjl6l"))
-             (patches
-               (list
-                 (origin
-                   (method url-fetch)
-                   ;; This patch fixes an issue with python-urwid-2.1.0
-                   (uri "https://github.com/pimutils/khal/commit/2c5990c2de2015b251ba23617faa40ee11b8c22a.patch")
-                   (file-name "khal-compat-urwid-2.1.0.patch")
-                   (sha256
-                    (base32
-                     "11nd8hkjz68imwqqn0p54zmb53z2pfxmzchaviy7jc1ky5s9l663")))))))
+              (method url-fetch)
+              (uri (pypi-uri "khal" version))
+              (sha256
+               (base32
+                "11qhrga44knlnp88py9p547d4nr5kn041d2nszwa3dqw7mf22ks9"))))
     (build-system python-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases
@@ -198,19 +188,14 @@  data units.")
              "doc/build/man/khal.1"
              (string-append (assoc-ref outputs "out") "/share/man/man1"))
             #t))
-        (add-before 'check 'fix-tests
-          (lambda _
-            ;; Reported upstream: <https://github.com/pimutils/khal/issues/947>.
-            (substitute* "tests/cli_test.py"
-             (("Invalid value for \"\\[ICS\\]\"") "Invalid value for \\'[ICS]\\'"))
-            #t))
         (replace 'check
-          (lambda* (#:key inputs #:allow-other-keys)
-            ;; The tests require us to choose a timezone.
-            (setenv "TZ"
-                    (string-append (assoc-ref inputs "tzdata")
-                                   "/share/zoneinfo/Zulu"))
-            (invoke "py.test" "tests"))))))
+          (lambda* (#:key inputs tests? #:allow-other-keys)
+            (if tests?
+                (begin
+                  ;; The tests require us to choose a timezone.
+                  (setenv "TZ" "UTC")
+                  ;; The disabled test expects /dev/tty.
+                  (invoke "pytest" "tests" "-k" "not test_import_from_stdin"))))))))
     (native-inputs
      `(("python-pytest" ,python-pytest)
        ("python-pytest-cov" ,python-pytest-cov)
@@ -229,6 +214,11 @@  data units.")
        ("python-icalendar" ,python-icalendar)
        ("python-tzlocal" ,python-tzlocal)
        ("python-urwid" ,python-urwid)
+       ("python-pytz" ,python-pytz)
+       ("python-setproctitle" ,python-setproctitle)
+       ("python-atomicwrites" ,python-atomicwrites)
+       ("python-click" ,python-click)
+       ("python-click-log" ,python-click-log)
        ("python-pyxdg" ,python-pyxdg)))
     (synopsis "Console calendar program")
     (description "Khal is a standards based console calendar program,