diff mbox series

[bug#44138] gnu: Add python-imap-tools.

Message ID 20201022144204.7603-1-r.majd@pantherx.org
State Accepted
Headers show
Series [bug#44138] gnu: Add python-imap-tools. | expand

Checks

Context Check Description
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Reza Alizadeh Majd Oct. 22, 2020, 2:42 p.m. UTC
* gnu/packages/python-web.scm (python-imap-tools): New variable.
---
 gnu/packages/python-web.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

Comments

Ludovic Courtès Oct. 24, 2020, 11:04 p.m. UTC | #1
Hi,

Reza Alizadeh Majd <r.majd@pantherx.org> skribis:

> * gnu/packages/python-web.scm (python-imap-tools): New variable.

[...]

> +    (synopsis "Work with email and mailbox by IMAP")
> +    (description
> +      "Work with email and mailbox by IMAP")

I expounded the description and committed, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b8b7ce9d31..0f9b4a4af6 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5164,3 +5164,22 @@  Encoding for HTTP.")
      "This module acts as a webbrowser solving Cloudflare's Javascript
 challenges.")
     (license license:expat)))
+
+(define-public python-imap-tools
+  (package
+    (name "python-imap-tools")
+    (version "0.27.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "imap_tools" version))
+        (sha256
+          (base32
+            "0zd3dkahjc3np9b9zs9cqgmif1gd64ykl1ydw60k5l5zli4ydlk8"))))
+    (build-system python-build-system)
+    (arguments '(#:tests? #f))          ; tests require internet access
+    (home-page "https://github.com/ikvk/imap_tools")
+    (synopsis "Work with email and mailbox by IMAP")
+    (description
+      "Work with email and mailbox by IMAP")
+    (license license:asl2.0)))