diff mbox series

[bug#44136] gnu: python-black: Update to 20.8b1.

Message ID 20201022141407.4392-1-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#44136] gnu: python-black: Update to 20.8b1. | expand

Checks

Context Check Description
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Tanguy LE CARROUR Oct. 22, 2020, 2:14 p.m. UTC
* gnu/packages/python-xyz.scm (python-black): Update to 20.8b1.
[arguments] Set PATH to make 1 test pass. Disable 1 failing test.
[propagated-inputs] Add python-mypy-extensions and python-typing-extensions.
---
 gnu/packages/python-xyz.scm | 18 ++++++++++++++----
 1 file changed, 14 insertions(+), 4 deletions(-)

Comments

Ludovic Courtès Oct. 23, 2020, 2:36 p.m. UTC | #1
Hi,

Tanguy Le Carrour <tanguy@bioneland.org> skribis:

> * gnu/packages/python-xyz.scm (python-black): Update to 20.8b1.
> [arguments] Set PATH to make 1 test pass. Disable 1 failing test.
> [propagated-inputs] Add python-mypy-extensions and python-typing-extensions.

Applied, thanks!

Ludo’.
Tanguy LE CARROUR Oct. 23, 2020, 3:49 p.m. UTC | #2
Le 10/23, Ludovic Courtès a écrit :
> Hi,
> 
> Tanguy Le Carrour <tanguy@bioneland.org> skribis:
> 
> > * gnu/packages/python-xyz.scm (python-black): Update to 20.8b1.
> > [arguments] Set PATH to make 1 test pass. Disable 1 failing test.
> > [propagated-inputs] Add python-mypy-extensions and python-typing-extensions.
> 
> Applied, thanks!

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 575ce40ac8..e3f8589249 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4053,14 +4053,14 @@  matching of file paths.")
 (define-public python-black
   (package
     (name "python-black")
-    (version "19.10b0")
+    (version "20.8b1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "black" version))
        (sha256
         (base32
-         "0f8mr0yzj78q1dx7v6ggbgfir2wv0n5z2shfbbvfdq7910xbgvf2"))))
+         "1spv6sldp3mcxr740dh3ywp25lly9s8qlvs946fin44rl1x5a0hw"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -4078,7 +4078,11 @@  matching of file paths.")
                                                   "")))))
              #t))
          (add-after 'unpack 'disable-broken-tests
-           (lambda _
+           (lambda* (#:key outputs inputs #:allow-other-keys)
+             ;; Make installed package available for running the tests
+             (setenv "PATH" (string-append (assoc-ref outputs "out") "/bin"
+                                           ":" (getenv "PATH")))
+
              ;; These tests are supposed to be skipped when the blackd
              ;; dependencies are missing, but this doesn't quite work.
              (substitute* "tests/test_black.py"
@@ -4092,15 +4096,21 @@  matching of file paths.")
              (substitute* "tests/test_black.py"
                (("( *)def test_self" match indent)
                 (string-append indent "@unittest.skip(\"guix\")\n" match)))
+
+             (substitute* "tests/test_black.py"
+               (("( *)def test_python38" match indent)
+                (string-append indent "@unittest.skip(\"guix\")\n" match)))
              #t)))))
     (propagated-inputs
      `(("python-click" ,python-click)
        ("python-attrs" ,python-attrs)
        ("python-appdirs" ,python-appdirs)
        ("python-pathspec" ,python-pathspec)
+       ("python-mypy-extensions" ,python-mypy-extensions)
        ("python-regex" ,python-regex)
        ("python-toml" ,python-toml)
-       ("python-typed-ast" ,python-typed-ast)))
+       ("python-typed-ast" ,python-typed-ast)
+       ("python-typing-extensions" ,python-typing-extensions)))
     (native-inputs
      `(("python-setuptools-scm" ,python-setuptools-scm)))
     (home-page "https://github.com/ambv/black")