diff mbox series

[bug#44127] Bombadillo build fix

Message ID 20201021232921.48d19496@riseup.net
State Accepted
Headers show
Series [bug#44127] Bombadillo build fix | expand

Checks

Context Check Description
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Csepp Oct. 21, 2020, 9:29 p.m. UTC
Just a quick fix. install-licenses was trying to overwrite a file
installed by a previous (custom) phase, but copy-file failed with a
permission error.

Comments

Christopher Baines Oct. 23, 2020, 4:27 p.m. UTC | #1
raingloom <raingloom@riseup.net> writes:

> Just a quick fix. install-licenses was trying to overwrite a file
> installed by a previous (custom) phase, but copy-file failed with a
> permission error.

I tweaked the commit message a bit, but I've pushed this now as
2371abcd0ece81d6b7ca3d03aff17c81bf8a5d85. Thanks!
diff mbox series

Patch

From 8260d3981f83b1446465ede31c8230d149422f6c Mon Sep 17 00:00:00 2001
From: raingloom <raingloom@riseup.net>
Date: Wed, 21 Oct 2020 23:22:26 +0200
Subject: [PATCH] gnu: Don't try to copy LICENSE twice in Bombadillo.

* gnu/packages/web-browsers.scm (bombadillo)[arguments]:
  Removed copy-file call for LICENSE.
---
 gnu/packages/web-browsers.scm | 1 -
 1 file changed, 1 deletion(-)

diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 862927242e..2220737daa 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -622,7 +622,6 @@  key-bindings and is fully configurable and extensible in Common Lisp.")
                              (pixdir (string-append sharedir "/pixmaps")))
                         (with-directory-excursion builddir
                           (install-file "bombadillo.desktop" appdir)
-                          (install-file "LICENSE" docdir)
                           (install-file "bombadillo.1" mandir)
                           (install-file "bombadillo-icon.png" pixdir)
                           #t)))))))
-- 
2.28.0