diff mbox series

[bug#44106] alacritty : add terminfo fix

Message ID 20201020220652.GA9741@bluewin.ch
State Accepted
Headers show
Series [bug#44106] alacritty : add terminfo fix | expand

Checks

Context Check Description
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Fulbert Oct. 20, 2020, 10:06 p.m. UTC
Hello Guix !

  When installed on an user extra-profile, `alacritty` does not add to
$TERMINFO_DIRS. Solved by using the attached patch. I have stolen this
fix from the guix `rxvt-unicode` package.

  Best regards,
  Fulbert
From f8a5219e412b3908f59512b7fccfc4d187ee2174 Mon Sep 17 00:00:00 2001
From: Fulbert <fulbert@bluewin.ch>
Date: Tue, 20 Oct 2020 23:51:19 +0200
Subject: [PATCH] Apply terminfo fix (https://bugs.gnu.org/22138) (stolen from
 rxvt-unicode package)

---
 gnu/packages/terminals.scm | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Ludovic Courtès Oct. 27, 2020, 4:41 p.m. UTC | #1
Hi,

Fulbert <fulbert@bluewin.ch> skribis:

>   When installed on an user extra-profile, `alacritty` does not add to
> $TERMINFO_DIRS. Solved by using the attached patch. I have stolen this
> fix from the guix `rxvt-unicode` package.

[...]

> Subject: [PATCH] Apply terminfo fix (https://bugs.gnu.org/22138) (stolen from
>  rxvt-unicode package)
>
> ---
>  gnu/packages/terminals.scm | 4 ++++
>  1 file changed, 4 insertions(+)
>
> diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
> index e596c1b81f..fc30550e3b 100644
> --- a/gnu/packages/terminals.scm
> +++ b/gnu/packages/terminals.scm
> @@ -1312,6 +1312,10 @@ made by suckless.")
>         ("ncurses" ,ncurses)
>         ("pkg-config" ,pkg-config)
>         ("python3" ,python)))
> +    (native-search-paths
> +      (list (search-path-specification
> +              (variable "TERMINFO_DIRS")
> +              (files '("share/terminfo")))))

I committed it (with a commit log that follows our conventions), but
added a FIXME as can be seen above in the file.  We usually avoid
workarounds for this bug but there’s a precedent in this file, so so be it!

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index e596c1b81f..fc30550e3b 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -1312,6 +1312,10 @@  made by suckless.")
        ("ncurses" ,ncurses)
        ("pkg-config" ,pkg-config)
        ("python3" ,python)))
+    (native-search-paths
+      (list (search-path-specification
+              (variable "TERMINFO_DIRS")
+              (files '("share/terminfo")))))
     (home-page "https://github.com/alacritty/alacritty")
     (synopsis "GPU-accelerated terminal emulator")
     (description