diff mbox series

[bug#44077,v2,1/2] gnu: Add python-poetry-core.

Message ID 20201020153921.18602-1-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#44077,v2,1/2] gnu: Add python-poetry-core. | expand

Checks

Context Check Description
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Tanguy LE CARROUR Oct. 20, 2020, 3:39 p.m. UTC
* gnu/packages/python-xyz.scm (python-poetry-core): New variable.
---
 gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 575ce40ac8..d9f8073dad 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12873,6 +12873,27 @@  powerful API: thread-safety; decorator syntax; support for memcached, redis,
 database, file, dict stores.  Cachy supports python versions 2.7+ and 3.2+.")
     (license license:expat)))
 
+(define-public python-poetry-core
+  (package
+    (name "python-poetry-core")
+    (version "1.0.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "poetry-core" version))
+        (sha256
+          (base32
+            "1mgv276h1iphn5fqhp2sgkgd5d0c39hs33vgaf157x5ri7rlyrka"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/python-poetry/poetry-core")
+    (synopsis "Poetry PEP 517 build back-end")
+    (description
+     "The @code{poetry-core} module provides a PEP 517 build back-end implementation
+developed for Poetry.  This project is intended to be a light weight, fully compliant,
+self-contained package allowing PEP 517 compatible build front-ends to build Poetry
+managed projects.")
+    (license license:expat)))
+
 (define-public poetry
   (package
     (name "poetry")