@@ -1579,7 +1579,8 @@ facilities for checking incoming mail.")
`(#:configure-flags '("--sysconfdir=/etc"
"--localstatedir=/var"
"--with-sqlite" ; not auto-detected
- "--with-lucene") ; not auto-detected
+ "--with-lucene" ; not auto-detected
+ "--with-moduledir=/usr/lib/dovecot")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-file-names
@@ -1596,9 +1597,13 @@ facilities for checking incoming mail.")
(("cat") (which "cat")))
#t))
(replace 'install
- (lambda* (#:key make-flags #:allow-other-keys)
+ (lambda* (#:key outputs make-flags #:allow-other-keys)
+ ;; The .la files don't like having the moduledir moved.
+ (for-each delete-file (find-files "." "\\.la"))
;; Simple hack to avoid installing a trivial README in /etc.
(apply invoke "make" "install" "sysconfdir=/tmp/bogus"
+ (string-append "moduledir=" (assoc-ref outputs "out")
+ "/lib/dovecot")
make-flags))))))
(home-page "https://www.dovecot.org")
(synopsis "Secure POP3/IMAP server")
From: Efraim Flashner <efraim@flashner.co.il> * gnu/packages/mail.scm (dovecot)[arguments]: Add configure-flag to set moduledir. Adjust custom 'install phase to override moduledir so it successfully installs. --- gnu/packages/mail.scm | 9 +++++++-- 1 file changed, 7 insertions(+), 2 deletions(-)