diff mbox series

[bug#44077,1/2] gnu: Add python-poetry-core.

Message ID 20201019132912.13941-1-tanguy@bioneland.org
State Accepted
Headers show
Series gnu: poetry: Update to 1.1.3. | expand

Checks

Context Check Description
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Tanguy LE CARROUR Oct. 19, 2020, 1:29 p.m. UTC
* gnu/packages/python-xyz.scm (python-poetry-core): New variable.
---
 gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Nicolas Goaziou Oct. 20, 2020, 11:51 a.m. UTC | #1
Hello,

Tanguy Le Carrour <tanguy@bioneland.org> writes:

> * gnu/packages/python-xyz.scm (python-poetry-core): New variable.

Thank you.

> +(define-public python-poetry-core
> +  (package
> +    (name "python-poetry-core")
> +    (version "1.0.0")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (pypi-uri "poetry-core" version))
> +        (sha256
> +          (base32
> +            "1mgv276h1iphn5fqhp2sgkgd5d0c39hs33vgaf157x5ri7rlyrka"))))

Nitpick: move the string on the same line as `base32'.

> +    (build-system python-build-system)
> +    (home-page "https://github.com/python-poetry/poetry-core")
> +    (synopsis "Poetry PEP 517 Build Backend")

Nitpick: I would avoid unnecessary capitalization: 


  Poetry PEP 517 build back-end

> +    (description
> +     "A PEP 517 build backend implementation developed for Poetry.  This project
> +is intended to be a light weight, fully compliant, self-contained package allowing
> +PEP 517 compatible build frontends to build Poetry managed projects.")

The first sentence should be complete, i.e., with a subject and a verb.

Otherwise, LGTM.

Regards,
Tanguy LE CARROUR Oct. 20, 2020, 3:30 p.m. UTC | #2
Hi,


Le 10/20, Nicolas Goaziou a écrit :
> Tanguy Le Carrour <tanguy@bioneland.org> writes:
> > +(define-public python-poetry-core
> > +  (package
> > +    (name "python-poetry-core")
> > +    (version "1.0.0")
> > +    (source
> > +      (origin
> > +        (method url-fetch)
> > +        (uri (pypi-uri "poetry-core" version))
> > +        (sha256
> > +          (base32
> > +            "1mgv276h1iphn5fqhp2sgkgd5d0c39hs33vgaf157x5ri7rlyrka"))))
> 
> Nitpick: move the string on the same line as `base32'.

I have no clue what the rule is, but… most (but not all!?) packages in
`gnu/packages/python-xyz.scm` have the string on a new line.
I'll leave it on a new line if it's OK with you.


> > +    (build-system python-build-system)
> > +    (home-page "https://github.com/python-poetry/poetry-core")
> > +    (synopsis "Poetry PEP 517 Build Backend")
> 
> Nitpick: I would avoid unnecessary capitalization: 
>   Poetry PEP 517 build back-end

Done!


> > +    (description
> > +     "A PEP 517 build backend implementation developed for Poetry.  This project
> > +is intended to be a light weight, fully compliant, self-contained package allowing
> > +PEP 517 compatible build frontends to build Poetry managed projects.")
> 
> The first sentence should be complete, i.e., with a subject and a verb.

My bad! Updated!


Thanks again for your time!
Nicolas Goaziou Oct. 21, 2020, 7:46 p.m. UTC | #3
Hello,

Tanguy Le Carrour <tanguy@bioneland.org> writes:

> Le 10/20, Nicolas Goaziou a écrit :

[...]

>> > +          (base32
>> > +            "1mgv276h1iphn5fqhp2sgkgd5d0c39hs33vgaf157x5ri7rlyrka"))))
>> 
>> Nitpick: move the string on the same line as `base32'.
>
> I have no clue what the rule is, but… most (but not all!?) packages in
> `gnu/packages/python-xyz.scm` have the string on a new line.

Note that "everyone else does this" may not be a strong reason to do
something. ;)

I suspect that most packages in this file come from the "pypi" importer,
which automatically adds this newline character, for some reason.

> I'll leave it on a new line if it's OK with you.

This spurious newline character hurts my eyes and my logic, but
ultimately, it will not hurt me. So, if that's important to you, go
ahead.

Regards,
Tanguy LE CARROUR Oct. 22, 2020, 7:22 a.m. UTC | #4
Hi Nicolas,


Le 10/21, Nicolas Goaziou a écrit :
> Tanguy Le Carrour <tanguy@bioneland.org> writes:
> > Le 10/20, Nicolas Goaziou a écrit :
> >> > +          (base32
> >> > +            "1mgv276h1iphn5fqhp2sgkgd5d0c39hs33vgaf157x5ri7rlyrka"))))
> >> 
> >> Nitpick: move the string on the same line as `base32'.
> >
> > I have no clue what the rule is, but… most (but not all!?) packages in
> > `gnu/packages/python-xyz.scm` have the string on a new line.
> 
> Note that "everyone else does this" may not be a strong reason to do
> something. ;)

+1 :-)
The thing is, I'm not yet sure to understand the coding style, and
`etc/indent-code.el` leaves you some (too much?) freedom.
I've been happily using Black [1] to format my Python code for some time now,
and I *might* have become a bit lazy!

[1]: https://github.com/psf/black


> I suspect that most packages in this file come from the "pypi" importer,
> which automatically adds this newline character, for some reason.
> 
> > I'll leave it on a new line if it's OK with you.

You've got me there! I imported it!
Actually, I'd rather put everything on a single line if it fits (and
`indent-code.el` does not complain when I put `sha256` and `base32` on the
same line). I just didn't want to be pointed at as "the guys who does
not split the line". ^_^'


> This spurious newline character hurts my eyes and my logic, but
> ultimately, it will not hurt me. So, if that's important to you, go
> ahead.

Updated and pushed!

Thanks again for your time and your advice!
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 575ce40ac8..75733f31ad 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12873,6 +12873,26 @@  powerful API: thread-safety; decorator syntax; support for memcached, redis,
 database, file, dict stores.  Cachy supports python versions 2.7+ and 3.2+.")
     (license license:expat)))
 
+(define-public python-poetry-core
+  (package
+    (name "python-poetry-core")
+    (version "1.0.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "poetry-core" version))
+        (sha256
+          (base32
+            "1mgv276h1iphn5fqhp2sgkgd5d0c39hs33vgaf157x5ri7rlyrka"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/python-poetry/poetry-core")
+    (synopsis "Poetry PEP 517 Build Backend")
+    (description
+     "A PEP 517 build backend implementation developed for Poetry.  This project
+is intended to be a light weight, fully compliant, self-contained package allowing
+PEP 517 compatible build frontends to build Poetry managed projects.")
+    (license license:expat)))
+
 (define-public poetry
   (package
     (name "poetry")