diff mbox series

[bug#44029,2/4] gnu: lxqt-session: wrap startlxqt executable

Message ID 20201016111719.26766-1-r.majd@pantherx.org
State Accepted
Headers show
Series lxqt-desktop-service-type | expand

Checks

Context Check Description
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Reza Alizadeh Majd Oct. 16, 2020, 11:17 a.m. UTC
* gnu/packages/lxqt.scm (lxqt-session)[arguments]: add new phase to wrap
lxqt-session and add base paths for lxqt and pcmanfm-qt config folders
in system profile to to XDG_CONFIG_DIRS.
---
 gnu/packages/lxqt.scm | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 67b75ced1e..3c4b2d4c50 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -876,7 +876,14 @@  allows for launching applications or shutting down the system.")
                (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
                 (string-append (assoc-ref outputs "out")
                                "/share/lxqt/translations")))
-             #t)))))
+             #t))
+         (add-after 'install 'wrap-program
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (wrap-program (string-append out "/bin/startlxqt")
+                 `("XDG_CONFIG_DIRS" ":" suffix ("/run/current-system/profile/share"
+                                                 "/run/current-system/profile/share/pcmanfm-qt")))
+               #t))))))
     (home-page "https://lxqt.github.io")
     (synopsis "Session manager for LXQt")
     (description "lxqt-session provides the standard session manager