diff mbox series

[bug#44008] gnu: Add tsukundere.

Message ID 20201015102040.12598-1-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series [bug#44008] gnu: Add tsukundere. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Leo Prikler Oct. 15, 2020, 10:20 a.m. UTC
* gnu/packages/game-development.scm (tsukundere): New variable.
---
 gnu/packages/game-development.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Christopher Baines Oct. 15, 2020, 7:55 p.m. UTC | #1
Leo Prikler <leo.prikler@student.tugraz.at> writes:

> * gnu/packages/game-development.scm (tsukundere): New variable.
> ---
>  gnu/packages/game-development.scm | 28 ++++++++++++++++++++++++++++
>  1 file changed, 28 insertions(+)
>
> diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
> index 061dc13f69..0f2734e3c4 100644
> --- a/gnu/packages/game-development.scm
> +++ b/gnu/packages/game-development.scm
> @@ -2476,3 +2476,31 @@ fully dynamic omnidirectional shadows, global illumination, HDR lighting,
>  deferred shading, morphological / temporal / multisample anti-aliasing, and
>  much more.")
>        (license license:zlib))))
> +
> +(define-public tsukundere
> +  (package
> +    (name "tsukundere")
> +    (version "0.2.0")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://gitlab.com/leoprikler/tsukundere")
> +                    (commit version)))
> +              (sha256
> +               (base32
> +                "0qmqch8hh7vsa8qaz853vwbkz0krb106955dnz8dsl7skbm5jpn6"))))
> +    (build-system gnu-build-system)
> +    (native-inputs
> +     `(("autoconf" ,autoconf-wrapper)
> +       ("automake" ,automake)
> +       ("guile" ,guile-3.0)
> +       ("pkg-config" ,pkg-config)))
> +    (propagated-inputs
> +     `(("guile-sdl2" ,guile3.0-sdl2)))
> +    (home-page "https://gitlab.com/leoprikler/tsukundere")
> +    (synopsis "Visual novel engine")
> +    (description "Tsukundere is a game engine geared heavily towards the
> +development of visual novels, written on top of Guile-SDL2.  It is still
> +experimental and at the time of writing contains little more than the Guile
> +modules, that make up its runtime.")
> +    (license license:lgpl3+)))

Thanks, I made a couple of changes detailed below, but pushed the
tweaked patch to master as 3e072a59be55107bdcde4d1eabe2c857a254ebcc.

Guix lint said "the source file name should contain the package name",
this is because the source file is a Git repository, and the default
name for those doesn't contain the package name:

→ ./pre-inst-env guix build -S tsukundere
/gnu/store/65xkcflmr0lwk1jzgrac1n28s9as65xn-git-checkout

It's useful to not have lots of ...-git-checkout directories in the
store, as it makes it harder to know what they are. This can be avoided
by adding a (file-name (git-file-name name version)) bit in to the
origin record.

Also, adding new packages to the bottom of modules can be problematic,
if others do similarly, because it makes applying the patches
awkward. For that reason, if you don't especially want the package to go
at the bottom of the module, slot it in somewhere else. I moved the
tsukundere package up to beneath the tiled package, as that's somewhat
alphabetically ordered.
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 061dc13f69..0f2734e3c4 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2476,3 +2476,31 @@  fully dynamic omnidirectional shadows, global illumination, HDR lighting,
 deferred shading, morphological / temporal / multisample anti-aliasing, and
 much more.")
       (license license:zlib))))
+
+(define-public tsukundere
+  (package
+    (name "tsukundere")
+    (version "0.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.com/leoprikler/tsukundere")
+                    (commit version)))
+              (sha256
+               (base32
+                "0qmqch8hh7vsa8qaz853vwbkz0krb106955dnz8dsl7skbm5jpn6"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("autoconf" ,autoconf-wrapper)
+       ("automake" ,automake)
+       ("guile" ,guile-3.0)
+       ("pkg-config" ,pkg-config)))
+    (propagated-inputs
+     `(("guile-sdl2" ,guile3.0-sdl2)))
+    (home-page "https://gitlab.com/leoprikler/tsukundere")
+    (synopsis "Visual novel engine")
+    (description "Tsukundere is a game engine geared heavily towards the
+development of visual novels, written on top of Guile-SDL2.  It is still
+experimental and at the time of writing contains little more than the Guile
+modules, that make up its runtime.")
+    (license license:lgpl3+)))