diff mbox series

[bug#43883] gnu: Add libebur128.

Message ID 20201009151256.7949-1-monego@posteo.net
State Accepted
Headers show
Series [bug#43883] gnu: Add libebur128. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Vinicius Monego Oct. 9, 2020, 3:12 p.m. UTC
* gnu/packages/audio.scm (libebur128): New variable.
---
 gnu/packages/audio.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Marius Bakke Oct. 13, 2020, 9:15 p.m. UTC | #1
Vinicius Monego <monego@posteo.net> writes:

> * gnu/packages/audio.scm (libebur128): New variable.

[...]
  
> +    (arguments
> +     `(;; Tests require .wav files that are not distributed with the code.
> +       ;; See https://github.com/jiixyj/libebur128/issues/82.
> +       #:tests? #f

It is easy to provide these data files using an (origin ...) in
native-inputs, like e.g. 'json-modern-cxx'.  Obviously we should check
the terms of use first, as the data set is unrelated to this package.

(I don't really have a strong opinion here, just sayin')

> +       #:configure-flags '("-DCMAKE_BUILD_TYPE=Release"

Note: you can use #:build-type "Release" instead.  The default is
"RelWithDebInfo", so it's customary to add a comment when changing it.
Is there a particular reason to not provide debugging information here?

Otherwise the patch LGTM.
Vinicius Monego Oct. 15, 2020, 11:56 p.m. UTC | #2
Marius Bakke writes:

> Vinicius Monego <monego@posteo.net> writes:
>
>> * gnu/packages/audio.scm (libebur128): New variable.
>
> [...]
>   
>> +    (arguments
>> +     `(;; Tests require .wav files that are not distributed with the code.
>> +       ;; See https://github.com/jiixyj/libebur128/issues/82.
>> +       #:tests? #f
>
> It is easy to provide these data files using an (origin ...) in
> native-inputs, like e.g. 'json-modern-cxx'.  Obviously we should check
> the terms of use first, as the data set is unrelated to this package.
>
> (I don't really have a strong opinion here, just sayin')
>

I had a look at the terms (link provided in the issue referenced above)
and commercial usage is forbidden, making the audio files nonfree. Also, the
zip file weighs 87 MB.

>> +       #:configure-flags '("-DCMAKE_BUILD_TYPE=Release"
>
> Note: you can use #:build-type "Release" instead.  The default is
> "RelWithDebInfo", so it's customary to add a comment when changing it.
> Is there a particular reason to not provide debugging information here?

Oh, I wasn't aware of #:build-type. Thanks.

I remove debugging information to save space. The ideal case is to move
it to a separate output as in

https://guix.gnu.org/manual/en/html_node/Installing-Debugging-Files.html

, but that is something I have yet to take a look at.

I will enable it again in the v2 and add a comment about the data.
Marius Bakke Oct. 18, 2020, 9:59 p.m. UTC | #3
Vinicius Monego <monego@posteo.net> writes:

> Marius Bakke writes:
>
>> Vinicius Monego <monego@posteo.net> writes:
>>
>>> * gnu/packages/audio.scm (libebur128): New variable.
>>
>> [...]
>>   
>>> +    (arguments
>>> +     `(;; Tests require .wav files that are not distributed with the code.
>>> +       ;; See https://github.com/jiixyj/libebur128/issues/82.
>>> +       #:tests? #f
>>
>> It is easy to provide these data files using an (origin ...) in
>> native-inputs, like e.g. 'json-modern-cxx'.  Obviously we should check
>> the terms of use first, as the data set is unrelated to this package.
>>
>> (I don't really have a strong opinion here, just sayin')
>>
>
> I had a look at the terms (link provided in the issue referenced above)
> and commercial usage is forbidden, making the audio files nonfree. Also, the
> zip file weighs 87 MB.

Oh, thanks for checking, too bad.

>>> +       #:configure-flags '("-DCMAKE_BUILD_TYPE=Release"
>>
>> Note: you can use #:build-type "Release" instead.  The default is
>> "RelWithDebInfo", so it's customary to add a comment when changing it.
>> Is there a particular reason to not provide debugging information here?
>
> Oh, I wasn't aware of #:build-type. Thanks.
>
> I remove debugging information to save space. The ideal case is to move
> it to a separate output as in
>
> https://guix.gnu.org/manual/en/html_node/Installing-Debugging-Files.html
>
> , but that is something I have yet to take a look at.
>
> I will enable it again in the v2 and add a comment about the data.

Excellent, applied!
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 0e93a7263e..bd88987e13 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -3060,6 +3060,33 @@  that toolkit will work in all hosts that use Suil automatically.
 Suil currently supports every combination of Gtk, Qt, and X11.")
     (license license:isc)))
 
+(define-public libebur128
+  (package
+    (name "libebur128")
+    (version "1.2.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/jiixyj/libebur128")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0n81rnm8dm1zmibkr2v3q79rsd609y0dbbsrbay18njcjva88p0g"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(;; Tests require .wav files that are not distributed with the code.
+       ;; See https://github.com/jiixyj/libebur128/issues/82.
+       #:tests? #f
+       #:configure-flags '("-DCMAKE_BUILD_TYPE=Release"
+                           "-DBUILD_STATIC_LIBS=OFF")))
+    (home-page "https://github.com/jiixyj/libebur128")
+    (synopsis "Library implementing the EBU R 128 loudness standard")
+    (description
+     "@code{libebur128} is a C library that implements the EBU R 128 standard
+for loudness normalisation.")
+    (license license:expat)))
+
 (define-public timidity++
   (package
     (name "timidity++")