diff mbox series

[bug#43870,core-updates] gnu: inetutils: Let telnetd and rlogind find login.

Message ID 20201008195749.8316-1-mike@rohleder.de
State Accepted
Headers show
Series [bug#43870,core-updates] gnu: inetutils: Let telnetd and rlogind find login. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Michael Rohleder Oct. 8, 2020, 7:57 p.m. UTC
Without the shadow input, configure doesn't find login and sets PATH_LOGIN to a
(wrong) default value, which means that rlogind and telnetd doesn't work.

* gnu/packages/admin.scm (inetutils): Let telnetd and rlogind find login.
[inputs]: Add shadow.
---
 gnu/packages/admin.scm | 1 +
 1 file changed, 1 insertion(+)

Comments

Ludovic Courtès Oct. 22, 2020, 2:35 p.m. UTC | #1
Hi,

Michael Rohleder <mike@rohleder.de> skribis:

> Without the shadow input, configure doesn't find login and sets PATH_LOGIN to a
> (wrong) default value, which means that rlogind and telnetd doesn't work.
>
> * gnu/packages/admin.scm (inetutils): Let telnetd and rlogind find login.
> [inputs]: Add shadow.

Applied to ‘core-updates’, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index e62a145614..600b0ce097 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -630,6 +630,7 @@  re-executing them as necessary.")
        ;; "Failed to tell switch -a apart from -A".
        #:parallel-tests? #f))
     (inputs `(("ncurses" ,ncurses)
+              ("shadow" ,shadow)    ;for login (used in telnetd and rlogind)
               ("readline" ,readline)))        ;for 'ftp'
     (native-inputs (if (member (%current-system)
                                (package-supported-systems net-tools))