diff mbox series

[bug#43864] gnu: beets: Skip failing tests.

Message ID 20201008103704.5885-1-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#43864] gnu: beets: Skip failing tests. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Tanguy LE CARROUR Oct. 8, 2020, 10:37 a.m. UTC
* gnu/packages/music.scm (beets)[phases]{disable-failing-tests}: New phase.
---
 gnu/packages/music.scm | 8 ++++++++
 1 file changed, 8 insertions(+)

Comments

Ludovic Courtès Oct. 10, 2020, 8:40 p.m. UTC | #1
Hello,

Tanguy Le Carrour <tanguy@bioneland.org> skribis:

> * gnu/packages/music.scm (beets)[phases]{disable-failing-tests}: New phase.

Applied, thanks!

Ludo’.
Tanguy LE CARROUR Oct. 11, 2020, 1:15 p.m. UTC | #2
Le 10/10, Ludovic Courtès a écrit :
> Tanguy Le Carrour <tanguy@bioneland.org> skribis:
> 
> > * gnu/packages/music.scm (beets)[phases]{disable-failing-tests}: New phase.
> 
> Applied, thanks!

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 1434af9788..6693f34037 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -29,6 +29,7 @@ 
 ;;; Copyright © 2020 Lars-Dominik Braun <lars@6xq.net>
 ;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3159,6 +3160,13 @@  websites such as Libre.fm.")
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         ;; Reported upstream: <https://github.com/beetbox/beets/issues/3771>.
+         ;; Disable the faulty test as the fix is unclear.
+         (add-after 'unpack 'disable-failing-tests
+           (lambda _
+             (substitute* "test/test_mediafile.py"
+               (("def test_read_audio_properties") "def _test_read_audio_properties"))
+             #t))
          (add-after 'unpack 'set-HOME
            (lambda _
              (setenv "HOME" (string-append (getcwd) "/tmp"))