diff mbox series

[bug#43809,1/1] gnu: emacs-tuareg: Update to 2.2.0-0.ccde45b.

Message ID 20201005072501.17848-1-zimon.toutoune@gmail.com
State Accepted
Headers show
Series gnu: emacs-tuareg: Update to 2.2.0-0.ccde45b. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Simon Tournier Oct. 5, 2020, 7:25 a.m. UTC
* gnu/packages/ocaml.scm (emacs-tuareg): Update to 2.2.0-0.ccde45b.
---
 gnu/packages/ocaml.scm | 84 +++++++++++++++++++++---------------------
 1 file changed, 43 insertions(+), 41 deletions(-)

Comments

Nicolas Goaziou Oct. 7, 2020, 7:43 p.m. UTC | #1
Hello,

zimoun <zimon.toutoune@gmail.com> writes:

> * gnu/packages/ocaml.scm (emacs-tuareg): Update to 2.2.0-0.ccde45b.

Thank you. Some minor comments follow.

> +  (let ((commit "ccde45bbc292123ec20617f1af7f7e19f7481545"))

I suggest to add a comment explaining why we do not use regular release.

> +    (package
> +      (name "emacs-tuareg")
> +      (version (git-version "2.2.0" "0" commit))
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://github.com/ocaml/tuareg")
> +               (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32 "1yxv4bnqarilnpg5j7wywall8170hwvm0q4xx06yqjgcn8pq1lac"))))
> +      (build-system gnu-build-system)
> +      (native-inputs `(("emacs" ,emacs-minimal)
> +                       ("opam" ,opam)))

Nitpick: Please move these inputs below `native-inputs'.

Otherwise, LGTM.

Regards,
Simon Tournier Oct. 8, 2020, 10:28 p.m. UTC | #2
Hi Nicolas,

Thank you for the review.  The v2 is sent.

   <http://issues.guix.gnu.org/43809#3>

On Wed, 7 Oct 2020 at 21:43, Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:

> > +  (let ((commit "ccde45bbc292123ec20617f1af7f7e19f7481545"))
>
> I suggest to add a comment explaining why we do not use regular release.

Done but I was not very inspired. :-)


> > +      (native-inputs `(("emacs" ,emacs-minimal)
> > +                       ("opam" ,opam)))
>
> Nitpick: Please move these inputs below `native-inputs'.

Thank you for the nitpick.  Done.  To be honest, I am not tweaked this line. :-)

Cheers,
simon
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index d61948afc3..c16fcc5bd1 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -15,6 +15,7 @@ 
 ;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -672,49 +673,50 @@  the OCaml core distribution.")
     (license license:lgpl2.1+))); with linking exception
 
 (define-public emacs-tuareg
-  (package
-    (name "emacs-tuareg")
-    (version "2.2.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/ocaml/tuareg")
-             (commit version)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "06zxnn85fk5087iq0zxc5l5n9fz8r0367wylmynbfhc9711vccy6"))))
-    (build-system gnu-build-system)
-    (native-inputs `(("emacs" ,emacs-minimal)
-                     ("opam" ,opam)))
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'make-git-checkout-writable
-           (lambda _
-             (for-each make-file-writable (find-files "."))
-             #t))
-         (delete 'configure)
-         (add-before 'install 'fix-install-path
-           (lambda* (#:key outputs #:allow-other-keys)
-             (substitute* "Makefile"
-               (("/emacs/site-lisp")
-                (string-append (assoc-ref %outputs "out")
-                               "/share/emacs/site-lisp/")))
-             #t))
-         (add-after 'install 'post-install
-           (lambda* (#:key outputs #:allow-other-keys)
-             (symlink "tuareg.el"
-                      (string-append (assoc-ref outputs "out")
-                                     "/share/emacs/site-lisp/"
-                                     "tuareg-autoloads.el"))
-             #t)))))
-    (home-page "https://github.com/ocaml/tuareg")
-    (synopsis "OCaml programming mode, REPL, debugger for Emacs")
-    (description "Tuareg helps editing OCaml code, to highlight important
+  (let ((commit "ccde45bbc292123ec20617f1af7f7e19f7481545"))
+    (package
+      (name "emacs-tuareg")
+      (version (git-version "2.2.0" "0" commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/ocaml/tuareg")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1yxv4bnqarilnpg5j7wywall8170hwvm0q4xx06yqjgcn8pq1lac"))))
+      (build-system gnu-build-system)
+      (native-inputs `(("emacs" ,emacs-minimal)
+                       ("opam" ,opam)))
+      (arguments
+       `(#:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'make-git-checkout-writable
+             (lambda _
+               (for-each make-file-writable (find-files "."))
+               #t))
+           (delete 'configure)
+           (add-before 'install 'fix-install-path
+             (lambda* (#:key outputs #:allow-other-keys)
+               (substitute* "Makefile"
+                 (("/emacs/site-lisp")
+                  (string-append (assoc-ref %outputs "out")
+                                 "/share/emacs/site-lisp/")))
+               #t))
+           (add-after 'install 'post-install
+             (lambda* (#:key outputs #:allow-other-keys)
+               (symlink "tuareg.el"
+                        (string-append (assoc-ref outputs "out")
+                                       "/share/emacs/site-lisp/"
+                                       "tuareg-autoloads.el"))
+               #t)))))
+      (home-page "https://github.com/ocaml/tuareg")
+      (synopsis "OCaml programming mode, REPL, debugger for Emacs")
+      (description "Tuareg helps editing OCaml code, to highlight important
 parts of the code, to run an OCaml REPL, and to run the OCaml debugger within
 Emacs.")
-    (license license:gpl2+)))
+      (license license:gpl2+))))
 
 (define-public ocaml-menhir
   (package