diff mbox series

[bug#43795] gnu: stockfish: Update to 12.

Message ID 20201004153359.31979-1-mike@rohleder.de
State Accepted
Headers show
Series [bug#43795] gnu: stockfish: Update to 12. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Michael Rohleder Oct. 4, 2020, 3:33 p.m. UTC
* gnu/packages/games.scm (stockfish): Update to 12.
---
 gnu/packages/games.scm | 17 ++++++++++++++---
 1 file changed, 14 insertions(+), 3 deletions(-)

Comments

Mathieu Othacehe Oct. 6, 2020, 8:02 a.m. UTC | #1
Hello,

> +                      (copy-file (assoc-ref inputs "net") "src/nn-82215d0fd0df.nnue")

You could wrap this line and also add a comment explaining why this
extra input is necessary.

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 28c1492b26..30aa7b9a25 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -11407,7 +11407,7 @@  etc.  You can also play games on FICS or against an engine.")
 (define-public stockfish
   (package
     (name "stockfish")
-    (version "11")
+    (version "12")
     (source
      (origin
        (method git-fetch)
@@ -11416,8 +11416,15 @@  etc.  You can also play games on FICS or against an engine.")
              (commit (string-append "sf_" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "12mppipinymj8s1ipq9a7is453vncly49c32ym9wvyklsgyxfzlk"))))
+        (base32 "0vcymbwp5nf114pp3ax40s21ki5dckda15vmhr77d1mnq3fn0l32"))))
     (build-system gnu-build-system)
+    (inputs
+     `(("net"
+        ,(origin
+           (method url-fetch)
+           (uri "https://tests.stockfishchess.org/api/nn/nn-82215d0fd0df.nnue")
+           (sha256
+            (base32 "1r4yqrh4di05syyhl84hqcz84djpbd605b27zhbxwg6zs07ms8c2"))))))
     (arguments
      `(#:tests? #f
        #:make-flags (list "-C" "src"
@@ -11433,7 +11440,11 @@  etc.  You can also play games on FICS or against an engine.")
                                             ("mips64el-linux" "general-64")
                                             (_ "general-32"))))
        #:phases (modify-phases %standard-phases
-                  (delete 'configure))))
+                  (delete 'configure)
+                  (add-after 'unpack 'copy-net
+                    (lambda* (#:key inputs #:allow-other-keys)
+                      (copy-file (assoc-ref inputs "net") "src/nn-82215d0fd0df.nnue")
+                      #t)))))
     (synopsis "Strong chess engine")
     (description
      "Stockfish is a very strong chess engines.  It is much stronger than the