diff mbox series

[bug#43761,v3] gnu: gmsh: Update to 4.6.0.

Message ID 20201002234004.18393-1-zimon.toutoune@gmail.com
State Accepted
Headers show
Series [bug#43761,v3] gnu: gmsh: Update to 4.6.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Simon Tournier Oct. 2, 2020, 11:40 p.m. UTC
Gmsh bundled METIS 5 released with Apache License 2.0 since upstream commit
eaff7f6477fe876991615cfa4b5832bd5f12994b.

* gnu/packages/maths.scm (gmsh): Update to 4.6.0.
(origin): Remove snippet about METIS.
(propagated-inputs): Replace 'opencascade-oce' by 'opencascade-occt'.
---
 gnu/packages/maths.scm | 16 +++++-----------
 1 file changed, 5 insertions(+), 11 deletions(-)

Comments

Ludovic Courtès Oct. 5, 2020, 8:05 a.m. UTC | #1
Hi!

zimoun <zimon.toutoune@gmail.com> skribis:

> Gmsh bundled METIS 5 released with Apache License 2.0 since upstream commit
> eaff7f6477fe876991615cfa4b5832bd5f12994b.
>
> * gnu/packages/maths.scm (gmsh): Update to 4.6.0.
> (origin): Remove snippet about METIS.
> (propagated-inputs): Replace 'opencascade-oce' by 'opencascade-occt'.

[...]

> -      (snippet
> -       ;; Remove non-free METIS code
> -       '(begin
> -          (delete-file-recursively "contrib/Metis")
> -          #t))))

Can we keep this snippet (without the now-obsolete comment), add our
‘metis’ package as an input, and have gmsh use it?

Thanks!

Ludo’.
Simon Tournier Oct. 5, 2020, 1:59 p.m. UTC | #2
Hi,

On Mon, 5 Oct 2020 at 10:05, Ludovic Courtès <ludovic.courtes@inria.fr> wrote:
> zimoun <zimon.toutoune@gmail.com> skribis:
>
> > Gmsh bundled METIS 5 released with Apache License 2.0 since upstream commit
> > eaff7f6477fe876991615cfa4b5832bd5f12994b.
> >
> > * gnu/packages/maths.scm (gmsh): Update to 4.6.0.
> > (origin): Remove snippet about METIS.
> > (propagated-inputs): Replace 'opencascade-oce' by 'opencascade-occt'.
>
> [...]
>
> > -      (snippet
> > -       ;; Remove non-free METIS code
> > -       '(begin
> > -          (delete-file-recursively "contrib/Metis")
> > -          #t))))
>
> Can we keep this snippet (without the now-obsolete comment), add our
> ‘metis’ package as an input, and have gmsh use it?

Done in v4.

Thanks,
simon
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index ce393cba80..89a33d1f4b 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -40,6 +40,7 @@ 
 ;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
 ;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
 ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2156,7 +2157,7 @@  This is the certified version of the Open Cascade Technology (OCCT) library.")
 (define-public gmsh
   (package
     (name "gmsh")
-    (version "2.16.0")
+    (version "4.6.0")
     (source
      (origin
       (method git-fetch)
@@ -2168,13 +2169,7 @@  This is the certified version of the Open Cascade Technology (OCCT) library.")
                                         version)))))
       (file-name (git-file-name name version))
       (sha256
-       (base32 "08rq4jajwmlpivnm9yifz2jhaivnz065lnk0h2zv773nwl9wf162"))
-      (modules '((guix build utils)))
-      (snippet
-       ;; Remove non-free METIS code
-       '(begin
-          (delete-file-recursively "contrib/Metis")
-          #t))))
+       (base32 "0m0pjxcy1bnr7a20i11lh0ih159pphq9wsvfjr3sfx4y3lginz5y"))))
     (build-system cmake-build-system)
     (propagated-inputs
      `(("fltk" ,fltk)
@@ -2184,15 +2179,14 @@  This is the certified version of the Open Cascade Technology (OCCT) library.")
        ("lapack" ,lapack)
        ("mesa" ,mesa)
        ("glu" ,glu)
-       ("opencascade-oce" ,opencascade-oce)
+       ("opencascade-occt" ,opencascade-occt)
        ("libx11" ,libx11)
        ("libxext" ,libxext)))
     (inputs
      `(("fontconfig" ,fontconfig)
        ("libxft" ,libxft)))
     (arguments
-     `(#:configure-flags `("-DENABLE_METIS:BOOL=OFF"
-                           "-DENABLE_BUILD_SHARED:BOOL=ON"
+     `(#:configure-flags `("-DENABLE_BUILD_SHARED:BOOL=ON"
                            "-DENABLE_BUILD_DYNAMIC:BOOL=ON")))
     (home-page "http://gmsh.info/")
     (synopsis "3D finite element grid generator")