diff mbox series

[bug#43771,4/5] Define postgresql-10

Message ID 20201002184059.29033-4-mail@cbaines.net
State Accepted
Headers show
Series PostgreSQL service improvements | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Christopher Baines Oct. 2, 2020, 6:40 p.m. UTC
So that it can be used, rather than postgresql. Because the major version of
the package is important, as it relates to the compatability with the data
files used by the service, it's useful to have a stable name to refer to a
package for version 10 of PostgreSQL.
---
 gnu/packages/databases.scm | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index ece4580c36..8cab3eb115 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1038,6 +1038,8 @@  TIMESTAMP.  It also supports storage of binary large objects, including
 pictures, sounds, or video.")
     (license (license:x11-style "file://COPYRIGHT"))))
 
+(define-public postgresql-10 postgresql)
+
 (define-public postgresql-11
   (package
     (inherit postgresql)