diff mbox series

[bug#43766] gnu: Add go-github-com-errata-ai-vale.

Message ID 20201002171317.1680-2-foo.dogsquared@gmail.com
State Accepted
Headers show
Series [bug#43766] gnu: Add go-github-com-errata-ai-vale. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Gabriel Arazas Oct. 2, 2020, 5:13 p.m. UTC
* gnu/packages/textutils.scm (go-github-com-errata-ai-vale): New variable.
---
 gnu/packages/textutils.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

Ludovic Courtès Nov. 2, 2020, 1:53 p.m. UTC | #1
Hi,

Gabriel Arazas <foo.dogsquared@gmail.com> skribis:

> * gnu/packages/textutils.scm (go-github-com-errata-ai-vale): New variable.

Applied, thanks!

Ludo’.
GNU bug Tracking System Nov. 2, 2020, 1:54 p.m. UTC | #2
Your bug report

#43766: [PATCH] gnu: Add go-github-com-errata-ai-vale.

which was filed against the guix-patches package, has been closed.

The explanation is attached below, along with your original report.
If you require more details, please reply to 43765@debbugs.gnu.org.
diff mbox series

Patch

diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 6653d01a31..f84fbc52ba 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -52,6 +52,7 @@ 
   #:use-module (gnu packages base)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages gcc)
+  #:use-module (gnu packages golang)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages java)
   #:use-module (gnu packages ncurses)
@@ -1173,3 +1174,35 @@  This package provides Python bindings.")
     (description "@command{aha} (Ansi Html Adapter) converts ANSI escape sequences
 of a Unix terminal to HTML code.")
     (license (list license:lgpl2.0+ license:mpl1.1))))
+
+(define-public go-github-com-errata-ai-vale
+  (package
+    (name "go-github-com-errata-ai-vale")
+    (version "2.4.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/errata-ai/vale")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32 "0d07fwha2220m8j24h527xl0gnl3svvyaywflgk5292d6g49ach2"))
+       (file-name (git-file-name name version))))
+    (build-system go-build-system)
+    (native-inputs
+     `(("github.com/sp13/afero" ,go-github-com-spf13-afero)
+       ("github.com/urfave/cli" ,go-github-com-urfave-cli)
+       ("github.com/olekukonko/tablewriter" ,go-github-com-olekukonko-tablewriter)
+       ("github.com/mitchellh/mapstructure" ,go-github-com-mitchellh-mapstructure)))
+    (arguments
+     `(#:import-path "github.com/errata-ai/vale"
+       #:install-source? #f))
+    (home-page "https://github.com/errata-ai/vale")
+    (synopsis "Fully customizable syntax-aware linter that focuses on your style")
+    (description
+     "Vale is a fully extensible linter that focuses on your own writing style
+by making use of rules in individual YAML files.  It is syntax-aware on markup
+languages such as HTML, Markdown, Asciidoc, and reStructuredText.  The community
+around it also has a list of style guides implemented with Vale in
+@url{https://github.com/errata-ai/styles, their styles repo}.")
+    (license license:expat)))