diff mbox series

[bug#43574,3/3] gnu: python-httpx: Update to 0.15.0.

Message ID 20200922233023.31089-2-monego@posteo.net
State Accepted
Headers show
Series [bug#43574,1/3] gnu: python-trio: Update to 0.17.0. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Vinicius Monego Sept. 22, 2020, 11:30 p.m. UTC
* gnu/packages/python-web.scm (python-httpx): Update to 0.15.0.
---
 gnu/packages/python-web.scm | 16 ++++++++++++----
 1 file changed, 12 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 536ad37117..6f9b56711f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4463,7 +4463,7 @@  Some things HTTP Core does do:
 (define-public python-httpx
   (package
     (name "python-httpx")
-    (version "0.14.3")
+    (version "0.15.0")
     (source
      (origin
        ;; PyPI tarball does not contain tests.
@@ -4473,7 +4473,7 @@  Some things HTTP Core does do:
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0mn8gqkgaij3s2pbwgrih20iq34f3f82dfvypaw3nnh7n63vna43"))))
+        (base32 "06w50br6b825sd70l6rm2s0fca1lnjbyx9n8nmcdlwg673z25kc6"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -4481,8 +4481,16 @@  Some things HTTP Core does do:
          (replace 'check
            (lambda _
              (invoke "pytest" "-vv" "-k"
-                     ;; This test tries to open an outgoing connection.
-                     "not test_connect_timeout[asyncio]"))))))
+                     ;; These tests try to open an outgoing connection.
+                     (string-append
+                      "not test_connect_timeout"
+                      " and not test_that_send_cause_async_client_to_be_not_"
+                      "closed"
+                      " and not test_that_async_client_caused_warning_when_"
+                      "being_deleted"
+                      " and not test_that_send_cause_client_to_be_not_closed"
+                      " and not test_async_proxy_close"
+                      " and not test_sync_proxy_close")))))))
     (native-inputs
      `(("python-autoflake" ,python-autoflake)
        ("python-black" ,python-black)