diff mbox series

[bug#43514,3/3] gnu: Add rust-path-abs.

Message ID 20200919161450.1343-2-foo.dogsquared@gmail.com
State Accepted
Headers show
Series [bug#43514,1/3] gnu: Add rust-stfu8. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Gabriel Arazas Sept. 19, 2020, 4:14 p.m. UTC
* gnu/packages/crates-io.scm (rust-path-abs-0.5): New variable.
---
 gnu/packages/crates-io.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

Comments

Gabriel Arazas Sept. 19, 2020, 4:29 p.m. UTC | #1
Part 2 of packaging bat with a bunch of missing dependencies.Here's what 
I've finished for now.Tested them all with ~guix build --rounds=4~ with 
only the x86_64 arch for now since I'm getting low disk space at the time.

Maybe I shouldn't include my comment inside of the patch. I only found 
out about --compose and --dry-run for git send-email JUST AFTER sending 
the patch series (why didn't I do that is beyond me). :-/

Apologies for the rookie mistake. For the reviewer, please remove those 
comments from the first patch if it's going to be applied. Thanks in 
advanced. :)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 81fabc6e72..b32e9decaf 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -17199,6 +17199,38 @@  synchronization primitives.")
      "Implementation detail of the paste crate.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-path-abs-0.5
+  (package
+    (name "rust-path-abs")
+    (version "0.5.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "path_abs" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "131qi5j201caraqz9rwbzk4mybd9bcrryrhf63lr9gz0xmnqwszb"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:cargo-inputs
+        (("rust-serde" ,rust-serde-1)
+         ("rust-serde-derive" ,rust-serde-derive-1)
+         ("rust-std-prelude" ,rust-std-prelude-0.2)
+         ("rust-stfu8" ,rust-stfu8-0.2))
+        #:cargo-development-inputs
+        (("rust-pretty-assertions"
+          ,rust-pretty-assertions-0.4)
+         ("rust-regex" ,rust-regex-0.2)
+         ("rust-serde-json" ,rust-serde-json-1)
+         ("rust-tempdir" ,rust-tempdir-0.3))))
+    (home-page "https://github.com/vitiral/path_abs")
+    (synopsis "Ergonomic paths and files in Rust")
+    (description
+      "Ergonomic paths and files in Rust.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-pbkdf2-0.4
   (package
     (name "rust-pbkdf2")