diff mbox series

[bug#43514,1/3] gnu: Add rust-stfu8.

Message ID 20200919160452.1281-1-foo.dogsquared@gmail.com
State Accepted
Headers show
Series [bug#43514,1/3] gnu: Add rust-stfu8. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Gabriel Arazas Sept. 19, 2020, 4:04 p.m. UTC
* gnu/packages/crates-io.scm (rust-stfu8-0.2): New variable.
* gnu/packages/crates-io.scm (rust-pretty-assertions-0.4): New variable.
* gnu/packages/crates-io.scm (rust-ansi-term-0.9): New variable.
* gnu/packages/crates-io.scm (rust-proptest-0.3): New variable.
* gnu/packages/crates-io.scm (rust-bit-set-0.4): New variable.
* gnu/packages/crates-io.scm (rust-bit-vec-0.4): New variable.

Part 2 of packaging bat with a bunch of missing dependencies.
Here's what I've finished for now.
Tested them all with ~guix build --rounds=4~ with only the x86_64 arch for now since I'm getting low disk space at the time.
---
 gnu/packages/crates-io.scm | 132 +++++++++++++++++++++++++++++++++++++
 1 file changed, 132 insertions(+)

Comments

Efraim Flashner Sept. 23, 2020, 5:56 a.m. UTC | #1
Can you split this into multiple commits? We prefer one package per
commit (unless they're too closely connected) and it makes it easier to
review.

On Sun, Sep 20, 2020 at 12:04:54AM +0800, Gabriel Arazas wrote:
> * gnu/packages/crates-io.scm (rust-stfu8-0.2): New variable.
> * gnu/packages/crates-io.scm (rust-pretty-assertions-0.4): New variable.
> * gnu/packages/crates-io.scm (rust-ansi-term-0.9): New variable.
> * gnu/packages/crates-io.scm (rust-proptest-0.3): New variable.
> * gnu/packages/crates-io.scm (rust-bit-set-0.4): New variable.
> * gnu/packages/crates-io.scm (rust-bit-vec-0.4): New variable.

If you put another dashed line (---) above your comment it doesn't show
up when the patch gets applied.

> 
> Part 2 of packaging bat with a bunch of missing dependencies.
> Here's what I've finished for now.
> Tested them all with ~guix build --rounds=4~ with only the x86_64 arch for now since I'm getting low disk space at the time.
> ---
>  gnu/packages/crates-io.scm | 132 +++++++++++++++++++++++++++++++++++++
>  1 file changed, 132 insertions(+)
> 
> diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
> index 31f6e674f5..304b37e4df 100644
> --- a/gnu/packages/crates-io.scm
> +++ b/gnu/packages/crates-io.scm
> @@ -520,6 +520,22 @@ text or blue underlined text, on ANSI terminals.")
>         #:cargo-inputs
>         (("rust-winapi" ,rust-winapi-0.3))))))
>  
> +(define-public rust-ansi-term-0.9
> +  (package
> +    (inherit rust-ansi-term-0.11)
> +    (name "rust-ansi-term")
> +    (version "0.9.0")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (crate-uri "ansi_term" version))
> +       (file-name
> +        (string-append name "-" version ".tar.gz"))
> +       (sha256
> +        (base32
> +         "1xif1bh938qpfc3d0f9xgidibpm65xix11w9gszwqnia00q7rb13"))))
> +    (arguments `())))
> +
>  (define-public rust-antidote-1.0
>    (package
>      (name "rust-antidote")
> @@ -1761,6 +1777,27 @@ that uses Serde for transforming structs into bytes and vice versa!")
>       "This package provides a set of bits.")
>      (license (list license:asl2.0 license:expat))))
>  
> +(define-public rust-bit-set-0.4
> +  (package
> +    (inherit rust-bit-set-0.5)
> +    (name "rust-bit-set")
> +    (version "0.4.0")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (crate-uri "bit-set" version))
> +       (file-name
> +        (string-append name "-" version ".tar.gz"))
> +       (sha256
> +        (base32
> +         "0320hhcbr73yzjpj2237vw2zq728yg7vmzb8dardg04ff4263gyr"))))
> +    (build-system cargo-build-system)
> +    (arguments
> +     `(#:cargo-inputs
> +       (("rust-bit-vec" ,rust-bit-vec-0.4))
> +       #:cargo-development-inputs
> +       (("rust-rand" ,rust-rand-0.3))))))
> +
>  (define-public rust-bit-vec-0.5
>    (package
>      (name "rust-bit-vec")
> @@ -1787,6 +1824,24 @@ that uses Serde for transforming structs into bytes and vice versa!")
>       "This package provides a vector of bits.")
>      (license (list license:expat license:asl2.0))))
>  
> +(define-public rust-bit-vec-0.4
> +  (package
> +    (inherit rust-bit-vec-0.5)
> +    (name "rust-bit-vec")
> +    (version "0.4.4")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (crate-uri "bit-vec" version))
> +       (file-name
> +        (string-append name "-" version ".tar.gz"))
> +       (sha256
> +        (base32
> +         "0pw902a8ail0k64a7092a8vngfzsq7xkj2r22hz6q1z62s5zzd02"))))
> +    (arguments
> +     `(#:cargo-development-inputs
> +       (("rust-rand" ,rust-rand-0.3))))))
> +
>  (define-public rust-bitflags-1
>    (package
>      (name "rust-bitflags")
> @@ -18804,6 +18859,27 @@ dependency to expose a precomputed hash.")
>  replacements, adding colorful diffs.")
>      (license (list license:expat license:asl2.0))))
>  
> +(define-public rust-pretty-assertions-0.4
> +  (package
> +    (inherit rust-pretty-assertions-0.6)
> +    (name "rust-pretty-assertions")
> +    (version "0.4.1")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (crate-uri "pretty_assertions" version))
> +       (file-name
> +        (string-append name "-" version ".tar.gz"))
> +       (sha256
> +        (base32
> +         "1llxlnhh4qz9kda27v6nllgzvgi1fv08i3djfk4zn6zlw8c53si8"))))
> +    (build-system cargo-build-system)
> +    (arguments
> +     `(#:skip-build? #t
> +       #:cargo-inputs
> +       (("rust-ansi-term" ,rust-ansi-term-0.9)
> +        ("rust-difference" ,rust-difference-1))))))
> +
>  (define-public rust-pretty-assertions-0.2
>    (package
>      (name "rust-pretty-assertions")
> @@ -19233,6 +19309,30 @@ macro use case.")
>         #:cargo-development-inputs
>         (("rust-regex" ,rust-regex-0.2))))))
>  
> +(define-public rust-proptest-0.3
> +  (package
> +    (inherit rust-proptest-0.7)
> +    (name "rust-proptest")
> +    (version "0.3.4")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (crate-uri "proptest" version))
> +       (file-name
> +        (string-append name "-" version ".tar.gz"))
> +       (sha256
> +        (base32
> +         "15633iq8x3x0im5vyij2gr8ncpflv4fa9w63rh94k20xhzv4m308"))))
> +    (arguments
> +     `(#:cargo-inputs
> +       (("rust-bit-set" ,rust-bit-set-0.4)
> +        ("rust-lazy-static" ,rust-lazy-static-0.2)
> +        ("rust-quick-error" ,rust-quick-error-1.2)
> +        ("rust-rand" ,rust-rand-0.3)
> +        ("rust-regex-syntax" ,rust-regex-syntax-0.4))
> +       #:cargo-development-inputs
> +       (("rust-regex" ,rust-regex-0.2))))))
> +
>  (define-public rust-psm-0.1
>    (package
>      (name "rust-psm")
> @@ -25027,6 +25127,38 @@ crate.")
>      (license (list license:asl2.0
>                     license:expat))))
>  
> +(define-public rust-stfu8-0.2
> +  (package
> +    (name "rust-stfu8")
> +    (version "0.2.4")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (crate-uri "stfu8" version))
> +       (file-name
> +        (string-append name "-" version ".tar.gz"))
> +       (sha256
> +        (base32
> +         "0xyv4axwc9rihg3f5fjdy7s0ahnz1iq6lq06blwkq2ihwcrh9xsb"))))
> +    (build-system cargo-build-system)
> +    (arguments
> +     `(#:cargo-inputs
> +       (("rust-lazy-static" ,rust-lazy-static-1)
> +        ("rust-regex" ,rust-regex-0.2))
> +       #:cargo-development-inputs
> +       (("rust-pretty-assertions"
> +         ,rust-pretty-assertions-0.4)
> +        ("rust-proptest" ,rust-proptest-0.3))))
> +    (home-page "https://github.com/vitiral/stfu8")
> +    (synopsis "Sorta Text Format in UTF-8")
> +    (description
> +     "STFU-8 is a hacky text encoding/decoding protocol for files that
> +partially uses UTF-8.  Its primary purpose is to allow a human to visualize and
> +edit data that is mostly UTF-8.  It will encode all non-UTF8-compliant bytes as
> +longform text (e.g., ESC becomes @code{r\x1B}) and tries to encode ill-formed
> +UTF-8.")
> +    (license (list license:expat license:asl2.0))))
> +
>  (define-public rust-stream-cipher-0.3
>    (package
>      (name "rust-stream-cipher")
> -- 
> 2.28.0
> 
> 
> 
>
Gabriel Arazas Sept. 24, 2020, 5:53 p.m. UTC | #2
> Can you split this into multiple commits? We prefer one package per
> commit (unless they're too closely connected) and it makes it easier to
> review.

Done and done. A new set of patches should be sent now.
Efraim Flashner Sept. 29, 2020, 6:58 a.m. UTC | #3
On Fri, Sep 25, 2020 at 01:53:32AM +0800, Gabriel Arazas wrote:
> > Can you split this into multiple commits? We prefer one package per
> > commit (unless they're too closely connected) and it makes it easier to
> > review.
> 
> Done and done. A new set of patches should be sent now.
> 

Thanks. Patches pushed. I changed rust-pretty-assertions-0.4 to only
skip the tests, not the entire build.
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 31f6e674f5..304b37e4df 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -520,6 +520,22 @@  text or blue underlined text, on ANSI terminals.")
        #:cargo-inputs
        (("rust-winapi" ,rust-winapi-0.3))))))
 
+(define-public rust-ansi-term-0.9
+  (package
+    (inherit rust-ansi-term-0.11)
+    (name "rust-ansi-term")
+    (version "0.9.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "ansi_term" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1xif1bh938qpfc3d0f9xgidibpm65xix11w9gszwqnia00q7rb13"))))
+    (arguments `())))
+
 (define-public rust-antidote-1.0
   (package
     (name "rust-antidote")
@@ -1761,6 +1777,27 @@  that uses Serde for transforming structs into bytes and vice versa!")
      "This package provides a set of bits.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-bit-set-0.4
+  (package
+    (inherit rust-bit-set-0.5)
+    (name "rust-bit-set")
+    (version "0.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "bit-set" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0320hhcbr73yzjpj2237vw2zq728yg7vmzb8dardg04ff4263gyr"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-bit-vec" ,rust-bit-vec-0.4))
+       #:cargo-development-inputs
+       (("rust-rand" ,rust-rand-0.3))))))
+
 (define-public rust-bit-vec-0.5
   (package
     (name "rust-bit-vec")
@@ -1787,6 +1824,24 @@  that uses Serde for transforming structs into bytes and vice versa!")
      "This package provides a vector of bits.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-bit-vec-0.4
+  (package
+    (inherit rust-bit-vec-0.5)
+    (name "rust-bit-vec")
+    (version "0.4.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "bit-vec" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0pw902a8ail0k64a7092a8vngfzsq7xkj2r22hz6q1z62s5zzd02"))))
+    (arguments
+     `(#:cargo-development-inputs
+       (("rust-rand" ,rust-rand-0.3))))))
+
 (define-public rust-bitflags-1
   (package
     (name "rust-bitflags")
@@ -18804,6 +18859,27 @@  dependency to expose a precomputed hash.")
 replacements, adding colorful diffs.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-pretty-assertions-0.4
+  (package
+    (inherit rust-pretty-assertions-0.6)
+    (name "rust-pretty-assertions")
+    (version "0.4.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "pretty_assertions" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1llxlnhh4qz9kda27v6nllgzvgi1fv08i3djfk4zn6zlw8c53si8"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-ansi-term" ,rust-ansi-term-0.9)
+        ("rust-difference" ,rust-difference-1))))))
+
 (define-public rust-pretty-assertions-0.2
   (package
     (name "rust-pretty-assertions")
@@ -19233,6 +19309,30 @@  macro use case.")
        #:cargo-development-inputs
        (("rust-regex" ,rust-regex-0.2))))))
 
+(define-public rust-proptest-0.3
+  (package
+    (inherit rust-proptest-0.7)
+    (name "rust-proptest")
+    (version "0.3.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "proptest" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "15633iq8x3x0im5vyij2gr8ncpflv4fa9w63rh94k20xhzv4m308"))))
+    (arguments
+     `(#:cargo-inputs
+       (("rust-bit-set" ,rust-bit-set-0.4)
+        ("rust-lazy-static" ,rust-lazy-static-0.2)
+        ("rust-quick-error" ,rust-quick-error-1.2)
+        ("rust-rand" ,rust-rand-0.3)
+        ("rust-regex-syntax" ,rust-regex-syntax-0.4))
+       #:cargo-development-inputs
+       (("rust-regex" ,rust-regex-0.2))))))
+
 (define-public rust-psm-0.1
   (package
     (name "rust-psm")
@@ -25027,6 +25127,38 @@  crate.")
     (license (list license:asl2.0
                    license:expat))))
 
+(define-public rust-stfu8-0.2
+  (package
+    (name "rust-stfu8")
+    (version "0.2.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "stfu8" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0xyv4axwc9rihg3f5fjdy7s0ahnz1iq6lq06blwkq2ihwcrh9xsb"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-lazy-static" ,rust-lazy-static-1)
+        ("rust-regex" ,rust-regex-0.2))
+       #:cargo-development-inputs
+       (("rust-pretty-assertions"
+         ,rust-pretty-assertions-0.4)
+        ("rust-proptest" ,rust-proptest-0.3))))
+    (home-page "https://github.com/vitiral/stfu8")
+    (synopsis "Sorta Text Format in UTF-8")
+    (description
+     "STFU-8 is a hacky text encoding/decoding protocol for files that
+partially uses UTF-8.  Its primary purpose is to allow a human to visualize and
+edit data that is mostly UTF-8.  It will encode all non-UTF8-compliant bytes as
+longform text (e.g., ESC becomes @code{r\x1B}) and tries to encode ill-formed
+UTF-8.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-stream-cipher-0.3
   (package
     (name "rust-stream-cipher")