diff mbox series

[bug#43504] gnu: Add scantailor-advanced.

Message ID 20200919055230.21174-1-mail@brendan.scot
State Accepted
Headers show
Series [bug#43504] gnu: Add scantailor-advanced. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Brendan Tildesley Sept. 19, 2020, 5:52 a.m. UTC
* gnu/packages/image-processing.scm (scantailor-advanced): New variable.
---
 gnu/packages/image-processing.scm | 50 +++++++++++++++++++++++++++++++
 1 file changed, 50 insertions(+)

Comments

Mathieu Othacehe Sept. 25, 2020, 12:29 p.m. UTC | #1
Hello,

> +         (uri (git-reference
> +               (url "https://github.com/brendan-t/scantailor-advanced")
> +               (commit commit)))

What's the reason for not using the upstream 1.0.16 release? Is the only
reason the addition of the Korean translation? In that case, it could be
contributed upstream or added as a side patch I guess.

Thanks,

Mathieu
Brendan Tildesley Sept. 25, 2020, 8:46 p.m. UTC | #2
On September 25, 2020 10:29:48 PM GMT+10:00, Mathieu Othacehe <othacehe@gnu.org> wrote:
>
>Hello,
>
>> +         (uri (git-reference
>> +               (url
>"https://github.com/brendan-t/scantailor-advanced")
>> +               (commit commit)))
>
>What's the reason for not using the upstream 1.0.16 release? Is the
>only
>reason the addition of the Korean translation? In that case, it could
>be
>contributed upstream or added as a side patch I guess.
>
>Thanks,
>
>Mathieu

Well I saw the merge request for it and it was ignored, so I just added it manually. Also I wasn't using the latest tag release but the latest commit because the release is 2 years old and there are many fixes and changes afterwards. This is not just the latest release plus the translation but the latest commit plus it, in my own repo. It didn't look like the channel owner was planning to make a release any time soon. Do you think I should just use the latest release then and not worry about it?
Mathieu Othacehe Oct. 1, 2020, 7:37 a.m. UTC | #3
Hello Brendan,

> Well I saw the merge request for it and it was ignored, so I just added it manually. Also I wasn't using the latest tag release but the latest commit because the release is 2 years old and there
> are many fixes and changes afterwards. This is not just the latest release plus the translation but the latest commit plus it, in my own repo. It didn't look like the channel owner was planning
> to make a release any time soon. Do you think I should just use the latest release then and not worry about it?

The project is not explicitly discontinued, so maybe you could package
the latest upstream commit. Regarding your translation commit, I saw you
submitted a MR a few days ago, let's see if it gets a review.

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 9158e14938..c480fae05a 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -11,6 +11,7 @@ 
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2020 Brendan Tildesley <mail@brendan.scot>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -33,6 +34,7 @@ 
   #:use-module (guix utils)
   #:use-module (guix download)
   #:use-module (guix git-download)
+  #:use-module (guix build-system qt)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
@@ -1015,3 +1017,51 @@  substitued, as well as collage-style photomosaics, in which rectangular parts
 of the source image at arbitrary positions (i.e. not aligned to a matrix) are
 substituted by matching images.")
       (license license:gpl2))))
+
+(define-public scantailor-advanced
+  (let ((commit "df1f8e25d16e08594d530c18de58f44b1fd7b0a5"))
+    (package
+      (name "scantailor-advanced")
+      (version (string-append "1.0.16-" (string-take commit 7)))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/brendan-t/scantailor-advanced")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0jycvw39yg17zrd2fdmihskkwb3jx2j50479bnqh50jcndligb3f"))))
+      (build-system qt-build-system)
+      (native-inputs
+       `(("qttools" ,qttools)))
+      (inputs
+       `(("boost" ,boost)
+         ("libjpeg" ,libjpeg-turbo)
+         ("libpng" ,libpng)
+         ("libtiff" ,libtiff)
+         ("qtbase" ,qtbase)
+         ("qtsvg" ,qtsvg)
+         ("zlib" ,zlib)))
+      (arguments
+       `(#:phases
+         (modify-phases %standard-phases
+           ;; Some tests require a display and fail with offscreen mode.
+           (add-after 'unpack 'disable-failing-tests
+             (lambda _
+               (setenv "ARGS" "--exclude-regex \"imageproc_.*\"")
+               #t)))))
+      (home-page "https://github.com/4lex4/scantailor-advanced")
+      (synopsis "Clean up scanned pages")
+      (description "Scan Tailor is an interactive post-processing tool for
+scanned pages.  It performs operations such as page splitting, deskewing,
+adding/removing borders, and others.  You give it raw scans, and you get pages
+ready to be printed or assembled into a PDF or DJVU file.  Scanning, optical
+character recognition, and assembling multi-page documents are out of scope of
+this project.
+
+Scan Tailer Advanced is a development of Scan Tailer that merges features and
+bug fixes from Scan Tailor Featured and Scan Tailor Enhanced versions.  Guix's
+version additionally includes a Korean translation.")
+      (license license:gpl3+))))