diff mbox series

[bug#43454,2/2] gnu: Add python-beren.

Message ID 20200916195706.25516-1-monego@posteo.net
State Accepted
Headers show
Series [bug#43454,1/2] gnu: Add python-apiron. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Vinicius Monego Sept. 16, 2020, 7:57 p.m. UTC
* gnu/packages/python-web.scm (python-beren): New variable.
---
 gnu/packages/python-web.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Mathieu Othacehe Sept. 18, 2020, 9:49 a.m. UTC | #1
> * gnu/packages/python-web.scm (python-beren): New variable.

Pushed both patches, thanks!

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index aaa406d547..b0ad2240b6 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1912,6 +1912,28 @@  services and endpoints with a unified interface for interacting with RESTful
 APIs.")
     (license license:expat)))
 
+(define-public python-beren
+  (package
+    (name "python-beren")
+    (version "0.7.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "beren" version))
+       (sha256
+        (base32 "1v3mdwfqsyza892zvs124ym9w1bkng1j56b7l4dwfjir3723xcgf"))))
+    (build-system python-build-system)
+    (arguments
+     ;; The test tries to open a connection to a remote server.
+     `(#:tests? #f))
+    (propagated-inputs
+     `(("python-apiron" ,python-apiron)))
+    (home-page "https://github.com/teffalump/beren")
+    (synopsis "REST client for Orthanc DICOM servers")
+    (description
+     "@code{beren} provides a REST client for Orthanc, a DICOM server.")
+    (license license:gpl3+)))
+
 (define-public python-requests
   (package
     (name "python-requests")