@@ -19,6 +19,7 @@
;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.com>
+;;; Copyright © 2020 André Batista <nandre@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5825,3 +5826,34 @@ with hardware support for AES New Instructions (AES-NI) and a
sufficiently recent Go runtime, it will transparently call crypto/aes
when NewCipher is invoked.")
(license (license:non-copyleft "file://LICENSE.txt")))))
+
+(define-public go-gitlab-com-yawning-utls
+ (package
+ (name "go-gitlab-com-yawning-utls")
+ (version "0.0.10-1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/yawning/utls.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "15c46s56r45n22rmq9spnczydnkqrnxff28h5mpnk5yvcqif3lgb"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:tests? #f ;; Tries to connect and fails.
+ #:import-path "gitlab.com/yawning/utls.git"))
+ (propagated-inputs
+ `(("go-schwanenlied-me-yawning-bsaes" ,go-schwanenlied-me-yawning-bsaes)
+ ("go-github-com-dsnet-compress" ,go-github-com-dsnet-compress)
+ ("go-golang-org-x-crypto" ,go-golang-org-x-crypto)))
+ (home-page "https://gitlab.com/yawning/utls.git")
+ (synopsis "Go library for uTLS")
+ (description "This library is a fork of the main Transport Layer Security
+protocol in Go (crypto/tls) which provides ClientHello fingerprinting resistance,
+low level access to handshakes and fake session tickets among other features.
+This fork was made for the specific purpose of improving obfs4proxy's meek_lite
+transport protocol.")
+ (license license:gpl3+)))
From 4f31263215dffb94e47a4c9e7256e095fb68c1e4 Mon Sep 17 00:00:00 2001 From: =?UTF-8?q?Andr=C3=A9=20Batista?= <nandre@riseup.net> Date: Mon, 14 Sep 2020 18:47:38 -0300 Subject: [PATCH] gnu: Add go-gitlab-com-yawning-utls. To: 42380@debbugs.gnu.org * gnu/packages/golang.scm (go-gitlab-com-yawning-utls): New variable. --- gnu/packages/golang.scm | 32 ++++++++++++++++++++++++++++++++ 1 file changed, 32 insertions(+)