@@ -5770,3 +5770,29 @@ J. Bernstein. ")
(description "Package uniuri generates random strings good for use in
Universal Resource Identifiers to uniquely identify objects.")
(license license:cc0))))
+
+(define-public go-github-com-dsnet-compress
+ (let ((commit "cc9eb1d7ad760af14e8f918698f745e80377af4f")
+ (revision "0"))
+ (package
+ (name "go-github-com-dsnet-compress")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dsnet/compress")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "159liclywmyb6zx88ga5gn42hfl4cpk1660zss87fkx31hdq9fgx"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/dsnet/compress"))
+ (home-page "https://github.com/dsnet/compress")
+ (synopsis "Go library for extended compression")
+ (description "This is a collection of compression related libraries.
+The goal of this project is to provide pure Go implementations for popular
+compression algorithms bey ond what the Go standard library provides.")
+ (license (license:non-copyleft "file://LICENSE.md")))))
From e539f026c99a4983713a60928b2be10d70dd3a91 Mon Sep 17 00:00:00 2001 From: =?UTF-8?q?Andr=C3=A9=20Batista?= <nandre@riseup.net> Date: Mon, 14 Sep 2020 18:31:36 -0300 Subject: [PATCH] gnu: Add go-github-com-dsnet-compress. To: 42380@debbugs.gnu.org * gnu/packages/golang.scm (go-github-com-dsnet-compress): New variable. --- gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++ 1 file changed, 26 insertions(+)