@@ -5745,3 +5745,28 @@ Pseudo Random Function which is suitable for usage in message authentication
codes and was based on the design created by Jean-Philippe Aumasson and Daniel
J. Bernstein. ")
(license license:cc0))))
+
+(define-public go-github-com-dchest-uniuri
+ (let ((commit "8902c56451e9b58ff940bbe5fec35d5f9c04584a")
+ (revision "0"))
+ (package
+ (name "go-github-com-dchest-uniuri")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dchest/uniuri")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1x5bsbm1nlphsv96zd0rbclfaa1swpz5bp14x7s5dbxp0awk2gd4"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/dchest/uniuri"))
+ (home-page "https://github.com/dchest/uniuri")
+ (synopsis "Go library for random URIs")
+ (description "Package uniuri generates random strings good for use in
+Universal Resource Identifiers to uniquely identify objects.")
+ (license license:cc0))))
From 46b0c175ce9c440c469c4456960adab9503c2bfa Mon Sep 17 00:00:00 2001 From: =?UTF-8?q?Andr=C3=A9=20Batista?= <nandre@riseup.net> Date: Mon, 14 Sep 2020 18:27:56 -0300 Subject: [PATCH] gnu: Add go-github-com-dchest-uniuri. To: 42380@debbugs.gnu.org * gnu/packages/golang.scm (go-github-com-dchest-uniuri): New variable. --- gnu/packages/golang.scm | 25 +++++++++++++++++++++++++ 1 file changed, 25 insertions(+)