@@ -5718,3 +5718,30 @@ is unmaintained. Newer software should use x-crypto instead.")
;; License file is referred but it is missing. Probably because the
;; author decided to discontinue the project.
(license (license:non-copyleft "file://ed25519.go")))))
+
+(define-public go-github-com-dchest-siphash
+ (let ((commit "34f201214d993633bb24f418ba11736ab8b55aa7")
+ (revision "0"))
+ (package
+ (name "go-github-com-dchest-siphash")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dchest/siphash")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "08s076y7vmjqnq7jz0762hkm896r6r31v8b31a3gy0n8rfa01k8k"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/dchest/siphash"))
+ (home-page "https://github.com/dchest/siphash")
+ (synopsis "Go library for siphash")
+ (description "Go implementation of SipHash-2-4, a fast short-input
+Pseudo Random Function which is suitable for usage in message authentication
+codes and was based on the design created by Jean-Philippe Aumasson and Daniel
+J. Bernstein. ")
+ (license license:cc0))))
From b1d59160bf4c444784f68b5b35d20c48cb1eb601 Mon Sep 17 00:00:00 2001 From: =?UTF-8?q?Andr=C3=A9=20Batista?= <nandre@riseup.net> Date: Mon, 14 Sep 2020 18:18:41 -0300 Subject: [PATCH] gnu: Add go-github-com-dchest-siphash. To: 42380@debbugs.gnu.org * gnu/packages/golang.scm (go-github-com-dchest-siphash): New variable. --- gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++ 1 file changed, 27 insertions(+)