diff mbox series

[bug#43426,1/1] gnu: gdsl: Replace 'url-fetch' by 'git-fetch'.

Message ID 20200915140343.15986-1-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Fix unreachable gdsl package | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Simon Tournier Sept. 15, 2020, 2:03 p.m. UTC
Fixes <https://debbugs.gnu.org/25913>.

* gnu/packages/datastructures.scm (gdsl)[source]: Replace 'url-fetch' by
'git-fetch'.
[home-page]: Update.
---
 gnu/packages/datastructures.scm | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/datastructures.scm b/gnu/packages/datastructures.scm
index 3203f91608..ac091500fc 100644
--- a/gnu/packages/datastructures.scm
+++ b/gnu/packages/datastructures.scm
@@ -37,14 +37,15 @@ 
     (name "gdsl")
     (version "1.8")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "http://download.gna.org/gdsl/"
-                                  "gdsl-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "")            ; only hosted on Software Heritage
+                    (commit "6adb53be8b8f9f2e4bbfc92d357eedeefb4c7430")))
               (sha256
                (base32
-                "1v64jvlnj8jfpphphgjgb36p0kv50kwfyqncf0y12f16v8ydyiaw"))))
+                "0a52g12d9sf9hhcyvwfd7xdazj2a9i9jh97cnlqf2ymvwnvjk1g0"))))
     (build-system gnu-build-system)
-    (home-page "http://home.gna.org/gdsl/")
+    (home-page "https://web.archive.org/web/20170502005430/http://home.gna.org/gdsl/")
     (synopsis "Generic data structures library")
     (description "The Generic Data Structures Library (GDSL) is a collection
 of routines for generic data structures manipulation.  It is a re-entrant