diff mbox series

[bug#43414,1/3] gnu: Add rust-lab.

Message ID 20200915005226.1978-1-foo.dogsquared@gmail.com
State Accepted
Headers show
Series [bug#43414,1/3] gnu: Add rust-lab. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Gabriel Arazas Sept. 15, 2020, 12:52 a.m. UTC
* gnu/packages/crates-io.scm (rust-lab-0.8): New variable.
* gnu/packages/crates-io.scm (rust-lab-0.7): New variable.
* gnu/packages/crates-io.scm (rust-lab-0.4): New variable.
---
 gnu/packages/crates-io.scm | 61 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 61 insertions(+)

Comments

Gabriel Arazas Sept. 15, 2020, 8:43 a.m. UTC | #1
This is supposedly for packaging bat ( https://github.com/sharkdp/bat ) 
but I guess I know now why with all of the missing dependencies and 
whatnot. ;p

For now, I'll iteratively add those packages. This is what I completed 
for today.

Btw, I just realized I forgot to add my name on the copyright headers. 
To whoever approved my changes, could they add it? Thanks in advanced. :-)

Best regards,

Gabriel Arazas
Efraim Flashner Sept. 16, 2020, 6:49 a.m. UTC | #2
On Tue, Sep 15, 2020 at 04:43:01PM +0800, Gabriel Arazas wrote:
> This is supposedly for packaging bat ( https://github.com/sharkdp/bat ) but
> I guess I know now why with all of the missing dependencies and whatnot. ;p
> 
> For now, I'll iteratively add those packages. This is what I completed for
> today.
> 
> Btw, I just realized I forgot to add my name on the copyright headers. To
> whoever approved my changes, could they add it? Thanks in advanced. :-)

Taken care of :)

> 
> Best regards,
> 
> Gabriel Arazas

Thanks. Patches pushed!
Gabriel Arazas Sept. 16, 2020, 11:36 a.m. UTC | #3
Of all the packages I forgot to test, it's the one with the obvious 
error. :/

Sorry for the rookie mistake, I triple-checked it and got the same error 
as you reported. I only tested two dependent packages (out of four 
according to the page, 
https://crates.io/crates/lab/reverse_dependencies, anyways) so far and 
it compiled successfully. I think it is safe to assume it's from the 
test suite.


> These two packages don't actually use the same dependencies as > rust-lab-0.8. I normally check https://crates.io/crates/package-name 
 > to make sure I have the correct dependencies.

I also forgot to check and correct the dependencies for the lower 
versions of rust-lab. Apologies for another mistake. I'll keep that in 
mind next time.

Anyways, thanks for checking things out. :) I'll have to clean up my 
workflow for next time, write up a note or something for reminders. Just 
getting used to packaging with different tools and stuff.


Best regards,

Gabriel Arazas
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 0f0f0c28c9..2f3cead9cf 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -12220,6 +12220,67 @@  currently supports parsing (fully conformant parser), formatting and comparing
 language tags.")
     (license license:expat)))
 
+(define-public rust-lab-0.8
+  (package
+    (name "rust-lab")
+    (version "0.8.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "lab" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "1ysnbviwi35mq6xyz9c59mpgigyfp4s4y2mispxzrms4vk83bx15"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:cargo-development-inputs
+        (("rust-approx" ,rust-approx-0.3)
+         ("rust-criterion" ,rust-criterion-0.3)
+         ("rust-lazy-static" ,rust-lazy-static-1.4)
+         ("rust-pretty-assertions"
+          ,rust-pretty-assertions-0.6)
+         ("rust-rand" ,rust-rand-0.7))))
+    (home-page "https://github.com/TooManyBees/lab")
+    (synopsis
+      "Converts RGB to CIE-LAB for Rust")
+    (description
+      "Tools for converting RGB colors to the CIE-LAB color space, and
+comparing differences in color.
+  ")
+    (license license:expat)))
+
+(define-public rust-lab-0.7
+  (package
+    (inherit rust-lab-0.8)
+    (name "rust-lab")
+    (version "0.7.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "lab" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "0g692d489lq01pv3mzfhxd98j0r22lw28l6bk112m74djlfzxdmw"))))))
+
+(define-public rust-lab-0.4
+  (package
+    (inherit rust-lab-0.8)
+    (name "rust-lab")
+    (version "0.4.4")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "lab" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "0h4ig5bvzmwlzd74zj7b4sh7kzi3c6mjjnw7yjz8ijxvr4mrcr1s"))))))
+
 (define-public rust-lalrpop-0.17
   (package
     (name "rust-lalrpop")