diff mbox series

[bug#43400,08/12] gnu: r-beachmat: Move to (gnu packages bioconductor).

Message ID 20200914160747.8983-8-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Move some BioConductor to (gnu packages bioconductor) | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Simon Tournier Sept. 14, 2020, 4:07 p.m. UTC
* gnu/packages/bioinformatics.scm (r-beachmat): Move from here...
* gnu/packages/bioconductor.scm (r-beachmat): ...to here.
---
 gnu/packages/bioconductor.scm   | 25 +++++++++++++++++++++++++
 gnu/packages/bioinformatics.scm | 25 -------------------------
 2 files changed, 25 insertions(+), 25 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index d9f7a9fb67..0ecb460bc4 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -8336,6 +8336,31 @@  routines.")
 objects from the @code{graph} package.")
     (license license:epl1.0)))
 
+(define-public r-beachmat
+  (package
+    (name "r-beachmat")
+    (version "2.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "beachmat" version))
+       (sha256
+        (base32
+         "1vl6jbf9ia78cm4ikdb8vz04jv4b46zhvg5i006c63a9pzw7zhxi"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-biocgenerics" ,r-biocgenerics)
+       ("r-delayedarray" ,r-delayedarray)
+       ("r-matrix" ,r-matrix)))
+    (native-inputs
+     `(("r-knitr" ,r-knitr)))
+    (home-page "https://bioconductor.org/packages/beachmat")
+    (synopsis "Compiling Bioconductor to handle each matrix type")
+    (description "This package provides a consistent C++ class interface for a
+variety of commonly used matrix types, including sparse and HDF5-backed
+matrices.")
+    (license license:gpl3)))
+
 (define-public r-singlecellexperiment
   (package
     (name "r-singlecellexperiment")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index ef6d6fc2d8..a84d19727c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10766,31 +10766,6 @@  block processing.")
 packages.")
     (license license:artistic2.0)))
 
-(define-public r-beachmat
-  (package
-    (name "r-beachmat")
-    (version "2.4.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (bioconductor-uri "beachmat" version))
-       (sha256
-        (base32
-         "1vl6jbf9ia78cm4ikdb8vz04jv4b46zhvg5i006c63a9pzw7zhxi"))))
-    (build-system r-build-system)
-    (propagated-inputs
-     `(("r-biocgenerics" ,r-biocgenerics)
-       ("r-delayedarray" ,r-delayedarray)
-       ("r-matrix" ,r-matrix)))
-    (native-inputs
-     `(("r-knitr" ,r-knitr)))
-    (home-page "https://bioconductor.org/packages/beachmat")
-    (synopsis "Compiling Bioconductor to handle each matrix type")
-    (description "This package provides a consistent C++ class interface for a
-variety of commonly used matrix types, including sparse and HDF5-backed
-matrices.")
-    (license license:gpl3)))
-
 (define-public r-dropbead
   (let ((commit "d746c6f3b32110428ea56d6a0001ce52a251c247")
         (revision "2"))