diff mbox series

[bug#43399,v2] gnu: Add ripmime.

Message ID 20200914084434.28911-1-sl@eauchat.org
State Accepted
Headers show
Series [bug#43399,v2] gnu: Add ripmime. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Sébastien Lerique Sept. 14, 2020, 8:44 a.m. UTC
* gnu/packages/mail.scm (ripmime): New variable.
---
This fixes the issues raised from the first patch (bug#43338).

 gnu/packages/mail.scm | 48 +++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 48 insertions(+)

Comments

Ludovic Courtès Sept. 14, 2020, 9:01 p.m. UTC | #1
Hi,

Sébastien Lerique <sl@eauchat.org> skribis:

> * gnu/packages/mail.scm (ripmime): New variable.

Perfect, applied!

> This fixes the issues raised from the first patch (bug#43338).

Note: since each message to guix-patches opens a new issue at
<https://issues.guix.gnu.org>, make sure to send followups to
NNN@debbugs.gnu.org, where NNN is the issue number of your v1.
(In this case I merged the two issues, no big deal; just so you know!)

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 4a9c6fc90f..bb9dc91607 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -627,6 +627,54 @@  Extension (MIME).")
                (base32
                 "0slzlzcr3h8jikpz5a5amqd0csqh2m40gdk910ws2hnaf5m6hjbi"))))))
 
+(define-public ripmime
+  ;; Upstream does not tag or otherwise provide any releases (only a version
+  ;; number in the source)
+  (let ((commit "a556ffe08d620602475c976732e8e1a82f3169e9")
+        (revision "1"))
+    (package
+      (name "ripmime")
+      (version (git-version "1.4.0.10" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/inflex/ripMIME")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1z8ar8flvkd9q3ax4x28sj5pyq8ykk5pq249y967lj2406lxparh"))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:phases
+         (modify-phases %standard-phases
+           ;; Source has no configure script
+           (delete 'configure)
+           ;; Buildcodes make the build non-reproducible; remove them
+           (add-after 'unpack 'strip-buildcodes
+             (lambda _
+               (substitute* "generate-buildcodes.sh"
+                 (("`date \\+%s`") "0")
+                 (("`date`") "0")
+                 (("`uname -a`") "Guix"))
+               #t))
+           ;; https://github.com/inflex/ripMIME/pull/16 makes 'mkdir-p-bin-man unnecessary
+           (add-before 'install 'mkdir-p-bin-man
+             (lambda _
+               (mkdir-p (string-append (assoc-ref %outputs "out") "/bin"))
+               (mkdir-p (string-append (assoc-ref %outputs "out") "/man"))
+               #t)))
+         ;; Makefile has no tests
+         #:tests? #f
+         #:make-flags (list (string-append "LOCATION=" (assoc-ref %outputs "out"))
+                            "CC=gcc")))
+      (synopsis "Extract attachments from MIME-encoded email")
+      (description
+       "ripMIME is a small program to extract the attached files out of a
+MIME-encoded email package.")
+      (home-page "https://github.com/inflex/ripMIME")
+      (license license:bsd-3))))
+
 (define-public bogofilter
   (package
     (name "bogofilter")