diff mbox series

[bug#43368] gnu: josm: Fix formatting and install more files.

Message ID 20200913084323.32740-1-mail@cbaines.net
State Accepted
Headers show
Series [bug#43368] gnu: josm: Fix formatting and install more files. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Christopher Baines Sept. 13, 2020, 8:43 a.m. UTC
This means that JOSM appears in the GNOME Shell menu.

* gnu/packages/geo.scm (josm)[source]: Replace tab character.
[arguments]: Reduce line length, and add install-share-directories phase.
---
 gnu/packages/geo.scm | 18 ++++++++++++++++--
 1 file changed, 16 insertions(+), 2 deletions(-)

Comments

Julien Lepiller Sept. 13, 2020, 10:26 a.m. UTC | #1
LGTM! Do you already have a copyright line?

Le 13 septembre 2020 04:43:23 GMT-04:00, Christopher Baines <mail@cbaines.net> a écrit :
>This means that JOSM appears in the GNOME Shell menu.
>
>* gnu/packages/geo.scm (josm)[source]: Replace tab character.
>[arguments]: Reduce line length, and add install-share-directories
>phase.
>---
> gnu/packages/geo.scm | 18 ++++++++++++++++--
> 1 file changed, 16 insertions(+), 2 deletions(-)
>
>diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
>index ab1d691c6c..a896364c35 100644
>--- a/gnu/packages/geo.scm
>+++ b/gnu/packages/geo.scm
>@@ -1290,7 +1290,7 @@ to the OSM opening hours specification.")
>               (modules '((guix build utils)))
>             (snippet
>              '(begin
>-		(for-each delete-file (find-files "." ".*.jar$"))
>+                (for-each delete-file (find-files "." ".*.jar$"))
>                 #t))))
>     (build-system ant-build-system)
>     (native-inputs
>@@ -1339,7 +1339,8 @@ to the OSM opening hours specification.")
>                        (filter
>                          (lambda (s)
>                            (let ((source (assoc-ref inputs "source")))
>-                             (not (equal? (substring s 0
>(string-length source)) source))))
>+                             (not (equal? (substring s 0
>(string-length source))
>+                                          source))))
>                          (string-split (getenv "CLASSPATH") #\:))
>                        ":"))
>              #t))
>@@ -1386,6 +1387,19 @@ to the OSM opening hours specification.")
>                                   "Is-Local-Build: true\n"
>                          "Build-Date: 1970-01-01 00:00:00 +0000\n"))))
>              #t))
>+         (add-after 'install 'install-share-directories
>+           (lambda* (#:key outputs #:allow-other-keys)
>+             (let ((out               (assoc-ref outputs "out"))
>+                   (share-directories '("applications" "icons" "man"
>"menu"
>+                                        "metainfo" "mime" "pixmaps")))
>+               (for-each (lambda (directory)
>+                           (copy-recursively (string-append
>+                                             
>"native/linux/tested/usr/share/"
>+                                              directory)
>+                                             (string-append
>+                                              out "/share/"
>directory)))
>+                         share-directories))
>+             #t))
>          (add-after 'install 'install-bin
>            (lambda* (#:key outputs inputs #:allow-other-keys)
>              (let* ((out (assoc-ref outputs "out"))
>-- 
>2.28.0
Christopher Baines Sept. 13, 2020, 12:25 p.m. UTC | #2
Julien Lepiller <julien@lepiller.eu> writes:

> LGTM! Do you already have a copyright line?

Great, I didn't have a copyright line in this file, so I've added on and
pushed as 1192ae940434808560b3170107e4ce44855816c3.

Thanks for taking a look,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index ab1d691c6c..a896364c35 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1290,7 +1290,7 @@  to the OSM opening hours specification.")
               (modules '((guix build utils)))
             (snippet
              '(begin
-		(for-each delete-file (find-files "." ".*.jar$"))
+                (for-each delete-file (find-files "." ".*.jar$"))
                 #t))))
     (build-system ant-build-system)
     (native-inputs
@@ -1339,7 +1339,8 @@  to the OSM opening hours specification.")
                        (filter
                          (lambda (s)
                            (let ((source (assoc-ref inputs "source")))
-                             (not (equal? (substring s 0 (string-length source)) source))))
+                             (not (equal? (substring s 0 (string-length source))
+                                          source))))
                          (string-split (getenv "CLASSPATH") #\:))
                        ":"))
              #t))
@@ -1386,6 +1387,19 @@  to the OSM opening hours specification.")
                                   "Is-Local-Build: true\n"
                                   "Build-Date: 1970-01-01 00:00:00 +0000\n"))))
              #t))
+         (add-after 'install 'install-share-directories
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out               (assoc-ref outputs "out"))
+                   (share-directories '("applications" "icons" "man" "menu"
+                                        "metainfo" "mime" "pixmaps")))
+               (for-each (lambda (directory)
+                           (copy-recursively (string-append
+                                              "native/linux/tested/usr/share/"
+                                              directory)
+                                             (string-append
+                                              out "/share/" directory)))
+                         share-directories))
+             #t))
          (add-after 'install 'install-bin
            (lambda* (#:key outputs inputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))