diff mbox series

[bug#43354,55/55] gnu: patchwork: Update to 2.2.2.

Message ID 20200912142911.6231-55-marius@gnu.org
State Accepted
Headers show
Series Django upgrade | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Marius Bakke Sept. 12, 2020, 2:29 p.m. UTC
* gnu/packages/patchutils.scm (patchwork): Update to 2.2.2.
[arguments]: Remove references to 'pwclient' which is now distributed
separately.
---
 gnu/packages/patchutils.scm | 17 ++---------------
 1 file changed, 2 insertions(+), 15 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index 335d251e74..12dd472c68 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -321,7 +321,7 @@  you to figure out what is going on in that merge you keep avoiding.")
 (define-public patchwork
   (package
     (name "patchwork")
-    (version "2.1.5")
+    (version "2.2.2")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -330,7 +330,7 @@  you to figure out what is going on in that merge you keep avoiding.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1n4hfwlgmw6mj5kp261zfx47mgb0l7g2yzl1rf0rnm8x69lr3as6"))))
+                "1cr3lhm589zhvcgfm8gni036866k2livq1rcxbnigjxlw9p5znaf"))))
     (build-system python-build-system)
     (arguments
      `(;; TODO: Tests require a running database
@@ -395,24 +395,11 @@  application = get_wsgi_application()\n") port)))))
                (for-each (lambda (file)
                            (install-file file (string-append out "/bin")))
                          (list
-                          (string-append out-site-packages
-                                         "patchwork/bin/pwclient")
                           (string-append out-site-packages
                                          "patchwork/bin/parsemail.sh")
                           (string-append out-site-packages
                                          "patchwork/bin/parsemail-batch.sh")))
 
-               ;; Delete the symlink to pwclient, and replace it with the
-               ;; actual file, as this can cause issues when serving the file
-               ;; from a webserver.
-               (let ((template-pwclient (string-append
-                                         out-site-packages
-                                         "patchwork/templates/patchwork/pwclient")))
-                 (delete-file template-pwclient)
-                 (copy-file (string-append out-site-packages
-                                           "patchwork/bin/pwclient")
-                            template-pwclient))
-
                ;; Collect the static assets, this includes JavaScript, CSS and
                ;; fonts. This is a standard Django process when running a
                ;; Django application for regular use, and includes assets for