diff mbox series

[bug#42899,v4,1/8] gnu: dovecot: Set moduledir to global directory.

Message ID 20200908135348.18551-1-levenson@mmer.org
State New
Headers show
Series [bug#42899,v4,1/8] gnu: dovecot: Set moduledir to global directory. | expand

Commit Message

Alexey Abramov Sept. 8, 2020, 1:53 p.m. UTC
From: Efraim Flashner <efraim@flashner.co.il>

* gnu/packages/mail.scm (dovecot)[arguments]: Add configure-flag to set
moduledir. Adjust custom 'install phase to override moduledir so it
successfully installs.
---
 gnu/packages/mail.scm | 9 +++++++--
 1 file changed, 7 insertions(+), 2 deletions(-)

Comments

dziltener--- via Guix-patches via Sept. 8, 2020, 2:03 p.m. UTC | #1
Alexey,

On 2020-09-08 13:53, Alexey Abramov wrote:
> v4

Thanks!  What's changed in v4?

I've been running a Dovecot with your outstanding patches for a week 
now, with 0 angry users; I'll review & try to push them later today.

Kind regards,

T G-R

Sent from a Web browser. Excuse or enjoy my brevity.
Alexey Abramov Sept. 8, 2020, 2:21 p.m. UTC | #2
Hi,

Tobias Geerinckx-Rice <me@tobias.gr> writes:

> Alexey,
>
> On 2020-09-08 13:53, Alexey Abramov wrote:
>> v4
>
> Thanks!  What's changed in v4?
>
> I've been running a Dovecot with your outstanding patches for a week
> now, with 0 angry users; I'll review & try to push them later today.

That was quick, thanks! Glad to hear everything is OK. Well, this time I sent a cover letter to a guix-devel only for some reason. =( I described the changes in general.

V4 doesn't have anything new. I just rebase v3 and provide v4 to let you guys apply/merge/work with them easier. Well, at least, I think it would be easier.
diff mbox series

Patch

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index beee68c67d..6068736508 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1460,7 +1460,8 @@  facilities for checking incoming mail.")
      `(#:configure-flags '("--sysconfdir=/etc"
                            "--localstatedir=/var"
                            "--with-sqlite"  ; not auto-detected
-                           "--with-lucene") ; not auto-detected
+                           "--with-lucene"  ; not auto-detected
+                           "--with-moduledir=/etc/dovecot/modules")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-file-names
@@ -1477,9 +1478,13 @@  facilities for checking incoming mail.")
                (("cat") (which "cat")))
              #t))
          (replace 'install
-           (lambda* (#:key make-flags #:allow-other-keys)
+           (lambda* (#:key outputs make-flags #:allow-other-keys)
+             ;; The .la files don't like having the moduledir moved.
+             (for-each delete-file (find-files "." "\\.la"))
              ;; Simple hack to avoid installing a trivial README in /etc.
              (apply invoke "make" "install" "sysconfdir=/tmp/bogus"
+                    (string-append "moduledir=" (assoc-ref outputs "out")
+                                   "/lib/dovecot")
                     make-flags))))))
     (home-page "https://www.dovecot.org")
     (synopsis "Secure POP3/IMAP server")