diff mbox series

[bug#43273] gnu: taglib: Fix 'taglib-config --libs' -L flag.

Message ID 20200908104835.12211-1-mike@rohleder.de
State Accepted
Headers show
Series [bug#43273] gnu: taglib: Fix 'taglib-config --libs' -L flag. | expand

Commit Message

Michael Rohleder Sept. 8, 2020, 10:48 a.m. UTC
* gnu/packages/mp3.scm (taglib): Add "" around the substitution of
ZLIB_LIBRARIES_FLAGS.
---
 gnu/packages/mp3.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Ludovic Courtès Sept. 9, 2020, 7:38 a.m. UTC | #1
Hi,

Michael Rohleder <mike@rohleder.de> skribis:

> * gnu/packages/mp3.scm (taglib): Add "" around the substitution of
> ZLIB_LIBRARIES_FLAGS.

Applied.  Thanks and sorry for the delay!

Ludo’.
Ludovic Courtès Sept. 9, 2020, 8:28 a.m. UTC | #2
Michael Rohleder <mike@rohleder.de> skribis:

> * gnu/packages/mp3.scm (taglib): Add "" around the substitution of
> ZLIB_LIBRARIES_FLAGS.
> ---
>  gnu/packages/mp3.scm | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
> index a7574f0cf9..2e9b023407 100644
> --- a/gnu/packages/mp3.scm
> +++ b/gnu/packages/mp3.scm
> @@ -182,9 +182,9 @@ a highly stable and efficient implementation.")
>                         ;; flag for zlib.
>                         (substitute* "CMakeLists.txt"
>                           (("set\\(ZLIB_LIBRARIES_FLAGS -lz\\)")
> -                          (string-append "set(ZLIB_LIBRARIES_FLAGS -L"
> +                          (string-append "set(ZLIB_LIBRARIES_FLAGS \"-L"
>                                           (assoc-ref inputs "zlib")
> -                                         " -lz)")))
> +                                         " -lz\")")))

As it turns out, we were also missing “/lib” there…  I’ve added it, and
hopefully now we’re all fine!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index a7574f0cf9..2e9b023407 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -182,9 +182,9 @@  a highly stable and efficient implementation.")
                        ;; flag for zlib.
                        (substitute* "CMakeLists.txt"
                          (("set\\(ZLIB_LIBRARIES_FLAGS -lz\\)")
-                          (string-append "set(ZLIB_LIBRARIES_FLAGS -L"
+                          (string-append "set(ZLIB_LIBRARIES_FLAGS \"-L"
                                          (assoc-ref inputs "zlib")
-                                         " -lz)")))
+                                         " -lz\")")))
                        #t)))))
     (inputs `(("zlib" ,zlib)))
     (home-page "https://taglib.org")