diff mbox series

[bug#43223] Update Picard (with a small patch)

Message ID 20200905171626.5819def9@riseup.net
State Accepted
Headers show
Series [bug#43223] Update Picard (with a small patch) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Csepp Sept. 5, 2020, 3:16 p.m. UTC
There are still some warnings printed, but I'll be honest, I have no
idea what they mean.
Everything seems to be working, so here is the patch.

Needed a small patch to fix a text. I'm not too jazzed about having to
log into GitHub of all things to send a pull request (because they
don't have issue tracking enabled), but I'll try to poke the fix
to them with a long stick.

Anyways, hopefully my commit messages are better now. ^u^

Comments

Ludovic Courtès Oct. 5, 2020, 8:39 a.m. UTC | #1
Hi,

raingloom <raingloom@riseup.net> skribis:

>>From b0480dd5a9367a31ff3b4f8948011ce9986e7da2 Mon Sep 17 00:00:00 2001
> From: raingloom <raingloom@riseup.net>
> Date: Sat, 5 Sep 2020 16:55:57 +0200
> Subject: [PATCH 1/2] gnu: Update python-mutagen to 1.45.1.
>
> * gnu/packages/music.scm (python-mutagen): Update python-mutagen to 1.45.1.
>   [native-inputs]: Add python-hypothesis and python-flake8.

[...]

>>From 84bf2cd161b477bbe223eee3b72041401adc1062 Mon Sep 17 00:00:00 2001
> From: raingloom <raingloom@riseup.net>
> Date: Sat, 5 Sep 2020 17:00:05 +0200
> Subject: [PATCH 2/2] gnu: Update picard to 2.4.4 with patch.
>
> * gnu/packages/music.scm (picard): Update to 2.4.4.
>   [native-inputs]: Add python-dateutil.
>   [source]: Add temporary patch to fix failing test due to missing "."
>   	    in temporary filename.
> * gnu/packages/patches/picard-fix-id3-rename-test.patch: New file.
> * gnu/local.mk (dist_patch_DATA): Add it.

Applied both, thank you, and sorry for the delay!

Ludo’.
diff mbox series

Patch

From 84bf2cd161b477bbe223eee3b72041401adc1062 Mon Sep 17 00:00:00 2001
From: raingloom <raingloom@riseup.net>
Date: Sat, 5 Sep 2020 17:00:05 +0200
Subject: [PATCH 2/2] gnu: Update picard to 2.4.4 with patch.

* gnu/packages/music.scm (picard): Update to 2.4.4.
  [native-inputs]: Add python-dateutil.
  [source]: Add temporary patch to fix failing test due to missing "."
  	    in temporary filename.
* gnu/packages/patches/picard-fix-id3-rename-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
---
 gnu/local.mk                                          |  1 +
 gnu/packages/music.scm                                |  8 +++++---
 gnu/packages/patches/picard-fix-id3-rename-test.patch | 11 +++++++++++
 3 files changed, 17 insertions(+), 3 deletions(-)
 create mode 100644 gnu/packages/patches/picard-fix-id3-rename-test.patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 3b97b8fdf3..67c67a8bc8 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1417,6 +1417,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/perl-module-pluggable-search.patch	\
   %D%/packages/patches/perl-reproducible-build-date.patch	\
   %D%/packages/patches/perl-www-curl-remove-symbol.patch	\
+  %D%/packages/patches/picard-fix-id3-rename-test.patch		\
   %D%/packages/patches/picprog-non-intel-support.patch		\
   %D%/packages/patches/pidgin-add-search-path.patch		\
   %D%/packages/patches/pidgin-libnm.patch			\
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index bbbb0d6819..a4cd1a9daa 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2807,7 +2807,7 @@  event-based scripts for scrobbling, notifications, etc.")
 (define-public picard
   (package
     (name "picard")
-    (version "2.1.3")
+    (version "2.4.4")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -2815,7 +2815,8 @@  event-based scripts for scrobbling, notifications, etc.")
                     "picard/picard-" version ".tar.gz"))
               (sha256
                (base32
-                "19w5k3bf4886gdycxjds9nkjvir0gwy2r5cqkz0lbls4ikk4y14f"))))
+                "1c5l7i43jaj3s4wklc0cba6nn2x9cmpcggk4q4h9m1bci2xilsiy"))
+              (patches (search-patches "picard-fix-id3-rename-test.patch"))))
     (build-system python-build-system)
     (arguments
      '(#:use-setuptools? #f
@@ -2834,7 +2835,8 @@  event-based scripts for scrobbling, notifications, etc.")
                  (assoc-ref inputs "chromaprint") "/bin/fpcalc")))
              #t)))))
     (native-inputs
-     `(("gettext" ,gettext-minimal)))
+     `(("gettext" ,gettext-minimal)
+       ("python-dateutil" ,python-dateutil)))
     (inputs
      `(("chromaprint" ,chromaprint)
        ("python-discid" ,python-discid)
diff --git a/gnu/packages/patches/picard-fix-id3-rename-test.patch b/gnu/packages/patches/picard-fix-id3-rename-test.patch
new file mode 100644
index 0000000000..3c4fa63c84
--- /dev/null
+++ b/gnu/packages/patches/picard-fix-id3-rename-test.patch
@@ -0,0 +1,11 @@ 
+Index: b/test/formats/test_id3.py
+===================================================================
+--- a/test/formats/test_id3.py
++++ b/test/formats/test_id3.py
+@@ -266,5 +266,5 @@
+         def test_rename_txxx_tags(self):
+             file_path = os.path.join('test', 'data', 'test-id3-rename-tags.mp3')
+-            filename = self.copy_file_tmp(file_path, 'mp3')
++            filename = self.copy_file_tmp(file_path, '.mp3')
+             raw_metadata = load_raw(filename)
+             self.assertIn('TXXX:Artists', raw_metadata)
-- 
2.28.0